Skip site navigation (1) Skip section navigation (2)

Re: Can't install pltcl

From: "Magnus Hagander" <mha(at)sollentuna(dot)net>
To: "Steve - DND" <postgres(at)digitalnothing(dot)com>,"postgres-win32" <pgsql-hackers-win32(at)postgresql(dot)org>
Subject: Re: Can't install pltcl
Date: 2005-04-14 11:27:46
Message-ID: 6BCB9D8A16AC4241919521715F4D8BCE6C72B6@algol.sollentuna.se (view raw or flat)
Thread:
Lists: pgsql-hackers-win32
> > Did you run depends logged in as yourself or as the postgres user?
> > (runas may be enough there) Could be different environments and/or 
> > permissions.
> 
> I originally ran it logged in as myself, but even when I used 
> runas with the postgres user everything checked out. I opened 
> up a command line to verify that c:\tcl\bin is in the path, 
> and it is. While looking at that though, I noticed the path 
> had c:\program files\postgresql\8.0\bin, but no path entry 
> for lib/, is that correct?

Hm. Yes, that's now it normally is.

I'm kind of lost on this :'( I've never seen a case where "depends"
works when running as postgresql, but not the backend itself. I think
you will need to hack up some better error messages for the dynamic
loader to get further.
(i was going to do that eventually, but I haven't had the time to look
into it yet)


//Magnus

Responses

pgsql-hackers-win32 by date

Next:From: Steve - DNDDate: 2005-04-14 18:30:42
Subject: Re: Can't install pltcl
Previous:From: rabtDate: 2005-04-12 21:34:07
Subject: Re: pgsql 8.x libpq.dll Installation problems

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group