Skip site navigation (1) Skip section navigation (2)

Re: Error starting service on Win2k

From: "Magnus Hagander" <mha(at)sollentuna(dot)net>
To: "Conal Tuohy" <Conal(dot)Tuohy(at)vuw(dot)ac(dot)nz>,<pgsql-bugs(at)postgresql(dot)org>
Subject: Re: Error starting service on Win2k
Date: 2004-09-19 20:30:07
Message-ID: 6BCB9D8A16AC4241919521715F4D8BCE475CED@algol.sollentuna.se (view raw or flat)
Thread:
Lists: pgsql-bugs
>I have installed 8.0-beta2-dev3 on Win2k but the service will 
>not start.
>
>Firstly, I couldn't install postgresql as a Windows service 
>using the installer - using the installer, I couldn't add 
>postgresql as a Windows service without being a local 
>administrator. However, if I was logged on as a local admin 
>then the service would install but there was an error reported 
>later on saying that the server wouldn't run because I was 
>administrator (don't have a log of that error, sorry).

You need two accounts. One administrator account that starts the
installer (this could be "Administrator" or cours e- definitly no need
to create a special user for this). Another account which is used to run
the eventual installed postgres. This is the account that you specify on
the service account screen in the installer. This account MUST NOT be an
administrator.


>failed to start. The Application event log shows the following 
>error (though NB the user account is a regular user, not a 
>"Power User" or "Administrator"):

Well, the systems says it is. Per FAQ 3.3 at
http://pginstaller.projects.postgresql.org/FAQ_windows.html, please
check the contents of your PU and Adm groups. They may contain other
nested groups.



//Magnus

pgsql-bugs by date

Next:From: Conal TuohyDate: 2004-09-19 23:58:33
Subject: Re: Error starting service on Win2k
Previous:From: Magnus HaganderDate: 2004-09-19 20:26:03
Subject: Re: psql can not connect to the server on Win2000 NT

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group