Skip site navigation (1) Skip section navigation (2)

Problem with standby

From: Jai Soni <jai(dot)soni(at)elbizsystems(dot)com>
To: pgsql-testers(at)postgresql(dot)org
Subject: Problem with standby
Date: 2010-09-08 12:28:42
Message-ID: 684197.22674.qm@web1207.biz.mail.gq1.yahoo.com (view raw or flat)
Thread:
Lists: pgsql-testers
Dear pgsql-testers

i have installed postgresql 9.0 beta1 and testing its streaming replication feature 
when i set up the replication env (i.e. primary and standby servers) everything was fine and the replication goes successful but last three-four days the standby server does not doing replication i have appended the log messages that i received in standby server

--------------------------------

LOG:  could not recognize system time zone
DETAIL:  The PostgreSQL time zone will be set to "Etc/GMT-5".
HINT:  You can specify the correct timezone in postgresql.conf.
LOG:  database system was shut down in recovery at 2010-09-08 17:26:47 ETC/GMT
LOG:  entering standby mode
LOG:  redo starts at 23/8300F5D4
LOG:  consistent recovery state reached at 23/9A4DFFAC
LOG:  invalid magic number 0000 in log file 35, segment 154, offset 5111808
LOG:  database system is ready to accept read only connections
LOG:  streaming replication successfully connected to primary
FATAL:  could not receive data from WAL stream: FATAL:  requested WAL segment 00000001000000230000009A has already been removed
    
LOG:  streaming replication successfully connected to primary
FATAL:  could not receive data from WAL stream: FATAL:  requested WAL segment 00000001000000230000009A has already been removed
    
LOG:  streaming replication successfully connected to primary
FATAL:  could not receive data from WAL stream: FATAL:  requested WAL segment 00000001000000230000009A has already been removed
    
LOG:  streaming replication successfully connected to primary
FATAL:  could not receive data from WAL stream: FATAL:  requested WAL segment 00000001000000230000009A has already been removed
    
LOG:  streaming replication successfully connected to primary
FATAL:  could not receive data from WAL stream: FATAL:  requested WAL segment 00000001000000230000009A has already been removed

.
.
.

endless repeats 


--------------------
i have tried to increase the wal_keep_segments configuration but still error was not resolved 
please guide me to correct this error



Thanks & Regards 
Jai Soni
98931-88891

Elbiz Systems Pvt. Limited 
201, Kanchan Sagar 
A.B. Road Indore (M.P.) 452001 INDIA 
(T): 0731 4067757 
(F): 0731 4064021  

P  Please  consider the environment before printing this email.
*********************************************************************************************************************************************** 
This e-mail message may contain proprietary, confidential or legally privileged information for the sole use of the person or entity to whom this message was originally addressed. Any review, e-transmission dissemination or other use of or taking of any action in reliance upon this information by persons or entities other than the intended recipient is prohibited. If you have received this e-mail in error kindly delete this e-mail from your records. If it appears that this mail has been forwarded to you without proper authority, please notify us immediately at info(at)elbizsystems(dot)com and delete this mail.


Responses

pgsql-testers by date

Next:From: Josh BerkusDate: 2010-09-08 17:14:09
Subject: Re: Problem with standby
Previous:From: Josh BerkusDate: 2010-09-03 18:02:11
Subject: Re: 9.0rc1 Solaris binaries on opensolaris

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group