Skip site navigation (1) Skip section navigation (2)

Postgresql8.4 install breaks Evolution on Ubuntu 9.10

From: Leonardo Camargo <camargoleonardo(at)gmail(dot)com>
To: pgsql-general(at)postgresql(dot)org
Subject: Postgresql8.4 install breaks Evolution on Ubuntu 9.10
Date: 2009-11-28 10:53:30
Message-ID: 6667c1ad0911280253l5a5db186oe5cd62db822b9b5d@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-general
Hi all,
I'm wondering if someone here know how to go about fixing this problem that
apparently affects everyone who manually install Postgresql8.4 on Ubuntu
Karmic(9.10).

Postgres installation seems to mess with something that renders other
applications unable to function. For instance my problem is with Evolution
Mail. This is the output I started getting after installing postgres:

evolution: /opt/PostgreSQL/8.4/lib/libxml2.so.2: no version information
available (required by evolution)
evolution: /opt/PostgreSQL/8.4/lib/libxml2.so.2: no version information
available (required by /usr/lib/evolution/2.28/libemiscwidgets.so.0)
evolution: /opt/PostgreSQL/8.4/lib/libxml2.so.2: no version information
available (required by /usr/lib/libgdata-1.2.so.1)
evolution: /opt/PostgreSQL/8.4/lib/libxml2.so.2: no version information
available (required by /usr/lib/libgdata-1.2.so.1)
evolution: /opt/PostgreSQL/8.4/lib/libxml2.so.2: no version information
available (required by /usr/lib/evolution/2.28/libetable.so.0)
evolution: /opt/PostgreSQL/8.4/lib/libxml2.so.2: no version information
available (required by /usr/lib/evolution/2.28/libeutil.so.0)
evolution: /opt/PostgreSQL/8.4/lib/libxml2.so.2: no version information
available (required by /usr/lib/evolution/2.28/libeutil.so.0)
evolution: /opt/PostgreSQL/8.4/lib/libxml2.so.2: no version information
available (required by /usr/lib/libebook-1.2.so.9)
evolution: /opt/PostgreSQL/8.4/lib/libxml2.so.2: no version information
available (required by /usr/lib/libedataserver-1.2.so.11)
evolution: /opt/PostgreSQL/8.4/lib/libxml2.so.2: no version information
available (required by /usr/lib/libsoup-2.4.so.1)
evolution: /opt/PostgreSQL/8.4/lib/libxml2.so.2: no version information
available (required by /usr/lib/libgnomevfs-2.so.0)
evolution: /opt/PostgreSQL/8.4/lib/libxml2.so.2: no version information
available (required by /usr/lib/libgnomevfs-2.so.0)
evolution: /opt/PostgreSQL/8.4/lib/libxml2.so.2: no version information
available (required by /usr/lib/libgnomevfs-2.so.0)
evolution: relocation error: /usr/lib/evolution/2.28/libeutil.so.0: symbol
xmlFirstElementChild, version LIBXML2_2.7.3 not defined in file libxml2.so.2
with link time reference

I can't be sure(no logs) but VMWare Workstation seems to have been affected
here too, can't get it to work anymore.

Other people having the same problem:
http://ubuntuforums.org/showthread.php?t=1307864
https://bugs.launchpad.net/ubuntu/+bug/461105


Best regards,
Leonardo C.

Responses

pgsql-general by date

Next:From: Sachin SrivastavaDate: 2009-11-28 11:03:30
Subject: Re: Postgresql8.4 install breaks Evolution on Ubuntu 9.10
Previous:From: admin@buydirect.net.auDate: 2009-11-28 10:46:18
Subject: Locale query

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group