Skip site navigation (1) Skip section navigation (2)

pg_restore problems

From: "Roopali Sharma" <roopali(dot)sharma(at)waterford(dot)org>
To: <pgsql-bugs(at)postgresql(dot)org>
Subject: pg_restore problems
Date: 2004-02-19 18:26:06
Message-ID: 661FA176BD6D144F91CE5DDCA6A9260208F983@postoffice.waterford.org (view raw or flat)
Thread:
Lists: pgsql-bugs
Hi,
 
I am trying to restore data from a production server (using Postgresql
7.3.x) to a test server using the latest release 7.4.1.
This is what I did:
1) dropdb -U postgres testdb
2) createdb -U postgres testdb
3) pg_restore -U postgres -O -d testdb data.tar
It throws this error:
pg_restore: [archiver (db)] could not execute query: ERROR:  could not
find function "dblink_tok" in file "/usr/local/pgsql7.4.1/lib/dblink.so"
 
Any input would be appreciated.
 
thanks
Roopali Sharma
Software Engineer
Waterford Institute
Phone: 801.938.1713 
  
************************************* 
This e-mail may contain privileged or confidential material intended for the named recipient only. 
If you are not the named recipient, delete this message and all attachments. 
Unauthorized reviewing, copying, printing, disclosing, or otherwise using information in this e-mail is prohibited. 
We reserve the right to monitor e-mail sent through our network.  
************************************* 

pgsql-bugs by date

Next:From: Shelby CainDate: 2004-02-19 19:57:33
Subject: ecpg mapping struct members for indicators incorrectly?
Previous:From: Alexander TroppmannDate: 2004-02-19 18:16:42
Subject: Maybe a bug found with nextval() function

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group