Skip site navigation (1) Skip section navigation (2)

pgagent fails to start by service command on redhat enterprise 5

From: "Do, Elvis L" <Elvis(dot)Do(at)gdit(dot)com>
To: "pgsql-admin(at)postgresql(dot)org" <pgsql-admin(at)postgresql(dot)org>
Subject: pgagent fails to start by service command on redhat enterprise 5
Date: 2011-02-01 00:35:03
Message-ID: 65E679D52B23864FAC609C4C4E116574848F4D8938@EXCHCCR01.ad.local (view raw or flat)
Thread:
Lists: pgsql-admin
Dear pgsql-admin,

Current operation system: Red hat Enterprise version 5.0.

I downloaded wxGTK (2.8.0) zip file from www.wxwidgests.org<https://teamworks.gdit.com/,DanaInfo=www.wxwidgests.org+>  and build and install it.
I downloaded pgadmin3 (1.8.0) RPM source code from pgadmin website http://www.postgresql.org/ftp/pgadmin3/release/v1.8.0/src/<https://teamworks.gdit.com/ftp/pgadmin3/release/v1.8.0/src/,DanaInfo=www.postgresql.org+> and build it. (This will include pgagent).

I can start pgagent from command line as without error and pgagent job schedule worked fine.
%/path to pgadmin3/bin/pgagent hostaddr=127.0.0.1 dbname=postgres user=postgres

However, when I tried to set up script to start pgagent when system reboot as from this link (http://www.postgresonline.com/journal/index.php?/archives/86-Yum-addendum-for-8.3.5-and-PgAgent.html) , I got error when I ran command service to start pgagent.
#service pgagent start
Starting PgAgent: /usr/local/pgadmin3/bin/pgagent: error while loading shared libraries: libwx_baseeu-2.8.so.0: cannot open shared object file: No such file or directory

Do you have any suggestion on this?
Thanks,

Elvis

pgsql-admin by date

Next:From: Antonio BiondoDate: 2011-02-01 17:44:18
Subject: maximum rows to retrive
Previous:From: Chris BarberDate: 2011-01-31 23:22:54
Subject: Autovacuums running on unused tables/databases

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group