Skip site navigation (1) Skip section navigation (2)

problema con tildes

From: "Christian Ortiz" <cpalst(at)gmail(dot)com>
To: pgsql-es-ayuda(at)postgresql(dot)org
Subject: problema con tildes
Date: 2007-12-28 16:27:24
Message-ID: 655c646a0712280827l4410ad80ua89915498a95f26e@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
Saludos

Tengo un problema, aun que no creo que sea de la configuracion de postgres.
Explico.
1. Tengo un servidor Linux con Postgres 8.2.4 instalado
2. Tengo una base de datos creada con el juego de caractares LATIN1 (use
tambien UTF8 y el resultado es el mismo)
3. Tengo un sistema hecho con MONO que se conecta a la base de datos
4. Si todos los usuarios son windows, no  hay problema, se graban las tildes
recibe las tildes y todo OK
5. Si todos los usuarios son Linux, no  hay problema, se graban las tildes
recibe las tildes y todo OK
6. Problema: Tenemos usuarios con windows XP y usuarios con LINUX, cuando un
usuario con XP graba con tildes los usuarios con LINUX ven caracteres
extraños, lo mismo sucede si el usuario LINUX  graba con tildes el usuario
XP ve caracteries extraños.
7. En linux tengo configurado el locale en : es_PE.UTF-8 y los windows,
tienen la configuracion regional en español (PERU)

es casi seguro que el problema es por el locale de los sitemas operativos.
alguna idea de como solucionarlo??? les agradeceria mucho


-- 
Christian

Responses

pgsql-es-ayuda by date

Next:From: Rodriguez FernandoDate: 2007-12-28 16:27:34
Subject: Re: Misma tabla dos bases de datos
Previous:From: Johnny VerdugoDate: 2007-12-28 15:09:51
Subject: copy Id serial

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group