"Kevin Grittner" <Kevin(dot)Grittner(at)wicourts(dot)gov> writes:
> Robert Haas <robertmhaas(at)gmail(dot)com> wrote:
> That seems unambiguous. I think I prefer it to
> IsXactIsoLevelXactSnapshotBased, so if there are no objections, I'll
> switch to XactUsesPerXactSnapshot. The current code uses a macro
> without parentheses; are you suggesting that the new code add those?
+1 for adding parens; we might want to make a function of it someday.
> Names starting with IsXactIsoLevel seem more technically correct,
> but the names get long enough that it seems to me that the meaning
> gets a bit lost in the jumble of words -- which is why I like the
> shorter suggested name. Any other opinions out there?
I don't much like the "XactUses..." aspect of it; that's just about
meaningless, because almost everything in PG could be said to be "used"
by a transaction. How about IsolationUsesXactSnapshot (versus
regards, tom lane
In response to
pgsql-hackers by date
|Next:||From: Kevin Grittner||Date: 2010-09-02 19:13:54|
|Subject: Re: "serializable" in comments and names|
|Previous:||From: Heikki Linnakangas||Date: 2010-09-02 18:30:59|
|Subject: Re: Interruptible sleeps (was Re: CommitFest 2009-07: Yay,
Kevin! Thanks, reviewers!)|