Skip site navigation (1) Skip section navigation (2)

PostgreSQL 9.0 alpha 4: build issues with OpenSSL 1.0.0-beta5

From: Lou Picciano <loupicciano(at)comcast(dot)net>
To: pgsql-testers <pgsql-testers(at)postgresql(dot)org>
Subject: PostgreSQL 9.0 alpha 4: build issues with OpenSSL 1.0.0-beta5
Date: 2010-02-25 00:39:24
Message-ID: 632370359.8843171267058364678.JavaMail.root@sz0093a.westchester.pa.mail.comcast.net (view raw or flat)
Thread:
Lists: pgsql-testers
Gents, 


Have a build with OpenSSL 0.9.8l. Rigorous testing to follow... 


Meanwhile, on a lark, tried to build against OpenSSL 1.0.0 beta5. config runs without incident. However, make generates: 


# make 
(in backend/parser section:) 
In file included from gram.y:11791: 
scan.c: In function `yy_try_NUL_trans': 
scan.c:16243: warning: unused variable `yyg' 


- THEN: 
gcc -O2 (...) -o libpq.so.5.3 
Text relocation remains referenced 
against symbol offset in file 
<unknown> 0x1654 /usr/local/openssl-100b5/lib/libssl.a(t1_enc.o) 
<unknown> 0x1658 /usr/local/openssl-100b5/lib/libssl.a(t1_enc.o) 
… (hundreds more) 
__umoddi3 0x64 /usr/local/openssl-100b5/lib/libcrypto.a(bn_word.o) 
__umoddi3 0xac /usr/local/openssl-100b5/lib/libcrypto.a(b_print.o) 
ld: fatal: relocations remain against allocatable but non-writable sections 
collect2: ld returned 1 exit status 
make[3]: *** [libpq.so.5.3] Error 1 


Don't know if this is a build bug, or if I have a platform mismatch (thought we were careful to build OpenSSL v1.0.0.0-beta 5 with 32-bit libs; perhaps not?) 


Lou

pgsql-testers by date

Next:From: Lou PiccianoDate: 2010-02-25 13:38:28
Subject: PostgreSQL 9.0 alpha 4: build issues - modules - with OpenSSL 0.9.8l
Previous:From: Lou PiccianoDate: 2010-02-24 20:28:58
Subject: Re: Postgres 9.0alpha4?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group