Skip site navigation (1) Skip section navigation (2)

Slony-I 1.2.10 Released

From: Christopher Browne <cbbrowne(at)ca(dot)afilias(dot)info>
To: pgsql-announce(at)postgresql(dot)org
Subject: Slony-I 1.2.10 Released
Date: 2007-06-26 18:46:48
Message-ID: 60ps3i1rl3.fsf@dba2.int.libertyrms.com (view raw or flat)
Thread:
Lists: pgsql-announce
After a considerable fix+test+refix+retest(+++) period, we are pleased
to announce the availability of version 1.2.10 of the Slony-I
replication system for PostgreSQL.  Listed below are the release notes
indicating the changes made since 1.2.10.

Thanks to all that reported issues, fixed bugs, and helped validate
things by running regression tests.

Please see the Slony-I web site <http://slony.info/> for links to
downloads.

RELEASE 1.2.10

- Fixed problem with EXECUTE SCRIPT (EXECUTE ONLY ON = <node>)

  - The script was being executed on too many nodes...

- Added a test script for log shipping

  ... And alter it to add invocation of a DDL script.  This
  allows testing for an event-counting problem in log shipping.

- Changes to support PostgreSQL 8.3 as VARATT_SIZEP has been deprecated

- in xxid.c, changes to support PostgreSQL 8.3 as tuple compression has
  more extensive support

  VARDATA_ANY(PG_DETOAST_DATUM_PACKED((PG_GETARG_DATUM(0))))
  tends to replace
  PG_GETARG_VARLENA(0)

- Slonik's SYNC command never recorded the new seqno in the admin
  conninfo, with potential wacky results for WAIT FOR EVENT

- Fix rpm build problem when the system has pg_config in both under
  /usr/local/pgsql/bin and /usr/bin

- Add init script for Red Hat / Fedora

- Fix archive log ship tracking. Slon now tracks the setsync status in
  memory and generates a void archive with the correct old,new event
  seqno for all events.

- EXECUTE SCRIPT wasn't setting sl_setsync, which broke WAIT FOR EVENT
  on these events

- Ducttape test #5 (which performs DDL changes) augmented to test use
  of WAIT FOR EVENT

- Backpatch fixes for restricted text casts in 8.3

  create_event() calls (notably, but they're not alone) need to be
  augmented to cast data types expressly.

- PostgreSQL 8.3 is now a supported version for 1.2.10

  The hope/intent is that 1.2.10 will be the last version of Slony-I
  in the "1.x" series, and will permit upgrades to PostgreSQL 8.3.
  The subsequent Slony-I 2.x series will require PostgreSQL 8.3.

- Discovered and documented a problem with UPDATE FUNCTIONS on
  versions 8.1.[0-3].

- Fixes to log shipping test

- Win32 fix for MinGW+gcc

- cvs distclean changed to clean the build up more...

- On copy_set() check that we have forwarded the confirmation of
  ENABLE_SUBSCRIPTION by the data provider only if the data provider
  is not the origin of the set.

- For logshipping we need to use the internally tracked ssy_seqno for
  SYNC events as well.  

  This allows "run_test.sh testlogship" to run successfully!
-- 
select 'cbbrowne' || '@' || 'linuxdatabases.info';
http://www3.sympatico.ca/cbbrowne/advocacy.html
Rules of the  Evil Overlord #187. "I will not  hold lavish banquets in
the middle of  a famine. The good PR among the  guests doesn't make up
for the bad PR among the masses."  <http://www.eviloverlord.com/>

pgsql-announce by date

Next:From: Vadim VinokurDate: 2007-06-26 20:07:03
Subject: PostgreSQL Maestro 7.6 released (UTF-8 support and more)
Previous:From: Selena DeckelmannDate: 2007-06-25 23:43:18
Subject: Re: Fwd: [ANNOUNCE] == PostgreSQL Weekly News - June 24 2007 ==

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group