Skip site navigation (1) Skip section navigation (2)

Re: postgres on MacOS X 10.1

From: "Scott W(dot) Hill" <shill(at)verisign(dot)com>
To: Moritz Gmelin <moritz(dot)gmelin(at)gmx(dot)de>
Cc: pgsql-ports(at)postgresql(dot)org
Subject: Re: postgres on MacOS X 10.1
Date: 2001-10-04 18:40:54
Message-ID: 5779AE4C-B8F7-11D5-8D89-003065BDABEC@verisign.com (view raw or flat)
Thread:
Lists: pgsql-ports
I have tried compiling Postgres under 10.1, with the -flat_namespace 
switch, but am still having other problems. I'll post if I get past 
them. I've stopped trying for right now, since I found a .pkg with int 
built under 10.1 at <http://www.entropy.ch/software/macosx/postgresql/>. 
It has a disclaimer that it hasn't been tested, but it seems to be 
working fine for me. YMMV.

--Scott

On Wednesday, October 3, 2001, at 08:10 AM, Moritz Gmelin wrote:

> Hi Postgres Team !
>
> I've been sucessfully using Postgres 7.1.3 on MacOS 10.0.4. Now I 
> updated to 10.1 (darwin 1.4). I can't create a new database anymore. 
> The backend hangs up somehow. Here's the log:
>
> DEBUG:  database system was shut down at 2001-10-03 15:34:52 CEST
> DEBUG:  CheckPoint record at (0, 1522656)
> DEBUG:  Redo record at (0, 1522656); Undo record at (0, 0); Shutdown 
> TRUE
> DEBUG:  NextTransactionId: 615; NextOid: 18720
> DEBUG:  database system is in production state
> Server process (pid 6629) exited with status 11 at Wed Oct  3 15:35:20 
> 2001
> Terminating any active server processes...
> Server processes were terminated at Wed Oct  3 15:35:20 2001
> Reinitializing shared memory and semaphores
> DEBUG:  database system was interrupted at 2001-10-03 15:35:08 CEST
> DEBUG:  CheckPoint record at (0, 1522656)
> DEBUG:  Redo record at (0, 1522656); Undo record at (0, 0); Shutdown 
> TRUE
> DEBUG:  NextTransactionId: 615; NextOid: 18720
> DEBUG:  database system was not properly shut down; automatic recovery 
> in progress...
> DEBUG:  ReadRecord: record with zero len at (0, 1522720)
> DEBUG:  redo is not required
>
> Is there any other log file I can look into ? Any known solutions to 
> the problem ?
>
> What I did :
>
> as postgres user :
>
> initdb -D /var/lib/pgsql (/var/lib/pgsql is owner by user postgres)
> createuser mgm (mgm ist me)
>
> as user mgm :
>
> createdb test
>
> I get the message that the backend has died (see above).
>
> Ideas ?
>
> Another thing :
>
> I tried to recompile the whole thing. But since OS 10.1 ld is switched 
> to two_level_namespaces (don't know exactly what it means) but you need 
> to change the Makefile.darwin to add the -flat_namespace switch somehow.
> But even with the newly compiled version it behaves just as noted above.
>
> Greetings
>
> Moritz
>
>
> ---------------------------(end of broadcast)---------------------------
> TIP 3: if posting/reading through Usenet, please send an appropriate
> subscribe-nomail command to majordomo(at)postgresql(dot)org so that your
> message can get through to the mailing list cleanly


In response to

pgsql-ports by date

Next:From: Marko KreenDate: 2001-10-04 19:26:53
Subject: Re: Porting from MySQL.
Previous:From: Bruce MomjianDate: 2001-10-04 15:01:51
Subject: Re: Who should I sent this to:

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group