Skip site navigation (1) Skip section navigation (2)

Re: Unable to add server in PGadmin

From: "manoj nair" <manoj(dot)nair1(at)gmail(dot)com>
To: "Dave Page" <dpage(at)postgresql(dot)org>
Cc: rod(at)iol(dot)ie, pgadmin-support(at)postgresql(dot)org
Subject: Re: Unable to add server in PGadmin
Date: 2007-12-10 13:29:54
Message-ID: 559cda0d0712100529p3db1e09ah7ce4ac462c133a08@mail.gmail.com (view raw or flat)
Thread:
Lists: pgadmin-support
Dave/rod,
       I checked Under File -> Options -> Preferences, check the 'Reset guru
hints'
option, click OK, and then tried connecting again.

This time i got some hint regarding Primary Keys .. but nothing on the
connection specific errors..

The PGAdmin on the vista box is working all fine ..
i have added 2 servers to it one with the local host and the other with an
ip address of a linux machine which has postgres running on it.... seems to
be working perfectly ,,,

But its just not possible to add the postgres server on the Vista box ...
through the pgadmin client on my machine
:) .donno what i am missing again ..

Settings for the postgres server on vista which i cross checked are as
follows ...

Firewall settings checked ...everything fine ,,,Postgres server is not
blocked ...
postgresql.conf -------- listen_address = '*'
pg_hba.conf -----(host all all  0.0.0.0/0 trust) so that any system can
connect remotely....

Thanks,
manoj


On Dec 10, 2007 5:22 PM, Dave Page <dpage(at)postgresql(dot)org> wrote:

> Raymond O'Donnell wrote:
> > On 10/12/2007 11:41, manoj nair wrote:
> >
> >>        The error message on the left most corner of PGAdmin
> >> says..."Connection to database ...Failed" and the
> >> add server form or dialog box pops up again.
> >> there is nothing much happening other than this.
> >
> > Yu should get a bit more than this....as an experiment, I stopped the
> > PostgreSQL service on my laptop (WinXP) and tried to connect with
> > pgAdmin - and a large window popped up quoting the error from libpq
> > ("could not connect to server: Connection refused (0x0000274D/10061) Is
> > the server running on host "127.0.0.1" and accepting TCP/IP connections
> > on port 5432?") and giving all sorts of useful advice.
> >
> > Do you not see something like this?
>
> Oh, I see how that can happen (the do not show this hint again' box has
> been checked).
>
> Under File -> Options -> Preferences, check the 'Reset guru hints'
> option, click OK, and then try connecting again.
>
> Regards, Dave.
>

In response to

Responses

pgadmin-support by date

Next:From: Raymond O'DonnellDate: 2007-12-10 13:41:53
Subject: Re: Unable to add server in PGadmin
Previous:From: Dave PageDate: 2007-12-10 11:58:50
Subject: Re: Fedora Core 8.0 status?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group