Skip site navigation (1) Skip section navigation (2)

Re: OSX errors

From: fmonkey(at)fmonkey(dot)net
To: fgoris(at)manxweb(dot)com
Cc: "Tai Pan" <taipan(at)rdslink(dot)ro>, pgadmin-support(at)postgresql(dot)org
Subject: Re: OSX errors
Date: 2004-12-01 14:37:20
Message-ID: 55555.65.86.32.148.1101911840.squirrel@65.86.32.148 (view raw or flat)
Thread:
Lists: pgadmin-support
> Mac OS X 10.3.6
> wxMac 2.5.3 (from tarfile)
> pgAdmin from CVS (11/30/04)
> Postgresql 7.4.5 (via fink)
>
> If anyone has any clues on where/how to start debugging, please let me
> know.

pgAdmin needs to be bundled with the wxWidgets resources in order to run.
The best way to do this is to build pgAdmin with an XCode project.  Also,
the recommended build procedure for wxWidgets is using the XCode project
(this from the wx guys themselves).  I've only just been able to get the
wx XCode to build, since their XCode project file doesn't get updated as
wx development progresses.  Then you'd have to build a pgAdmin XCode
project, and link to the wx libraries.  I've done this, and it builds, but
it has lots of problems, most of them wxWindows related.  So far, I
haven't had much luck getting the wx problems fixed, and I don't have a
lot of time to dedicate to tracking them down myself.  Perhaps if I get
some time tonight I can post a status and a pgAdmin XCode file that you
can use.

ahp


In response to

pgadmin-support by date

Next:From: Gino LucreziDate: 2004-12-01 14:43:07
Subject: Re: Installation problem with RC2
Previous:From: Andreas PflugDate: 2004-12-01 14:19:31
Subject: Re: Exception on connect

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group