Skip site navigation (1) Skip section navigation (2)

Configure/Build 9.0 rc1 - cannot build against python3.1, with two versions of python in the environment

From: Lou Picciano <LouPicciano(at)comcast(dot)net>
To: pgsql-testers(at)postgresql(dot)org
Subject: Configure/Build 9.0 rc1 - cannot build against python3.1, with two versions of python in the environment
Date: 2010-09-11 17:12:13
Message-ID: 5289151C-F7C2-4012-92F1-346FB9E1578F@comcast.net (view raw or flat)
Thread:
Lists: pgsql-testers
[TEST REPORT]
[Release]: 9.0 RC1
[Test Type]: Install (Build)
[Test]: Configure/Build 9.0 rc1 - cannot build against python3.1, with two versions of python in the environment
[Platform]: Solaris 10 Sparc E450 Quad
[Parameters]: 
--with-python \
--with-includes=/usr/local/include/python3.1:/usr/local/include:/usr/local/ssl/include \
--with-libraries=/usr/local/lib/python3.1:/usr/local/lib:/usr/local/ssl/lib \
CONFIGURE OUTPUT: -----------------------------------------
checking for python... /usr/bin/python
checking Python configuration directory... /usr/lib/python2.4/config
checking how to link an embedded Python application... -L/usr/lib -lpython2.4 -lresolv -lsocket -lnsl -lrt -ldl -lm
configure: using CPPFLAGS= -I/usr/local/include/libxml2  -I/usr/local/include/python3.1 -I/usr/local/include -I/usr/local/ssl/include
configure: using LDFLAGS= -L/usr/local/lib  -L/usr/local/lib/python3.1
[Failure]: Can't seem to definitively config PG to a specific version of python - v3.1, at /usr/local/bin/python3
[Results]: configure seems to pick up python 2.4 configuration, but apparently links to (desired) python 3.1 libs.
# ldd plpython2.so
        libpython2.4.so.1.0 =>   /usr/lib/libpython2.4.so.1.0
[Comments]: Tried first to see if configure picks up the PYTHONPATH env variable to find python's configuration.  No joy.  Using this variable might be a reasonable approach for configure?

Responses

pgsql-testers by date

Next:From: Josh BerkusDate: 2010-09-11 21:36:42
Subject: Re: Configure/Build 9.0 rc1 - cannot build against python3.1, with two versions of python in the environment
Previous:From: Josh BerkusDate: 2010-09-10 22:20:11
Subject: [Fwd: Re: [Fwd: [TEST REPORT] StackBuilder installs old JDBC driver (in strange location on 64-bit Windows)]]

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group