Skip site navigation (1) Skip section navigation (2)

Re: BUG #7588: pgsql 9.1 incompatible with zlib 1.27

From: John Marino <draco(at)marino(dot)st>
To: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: BUG #7588: pgsql 9.1 incompatible with zlib 1.27
Date: 2012-10-07 17:16:50
Message-ID: 5071B902.6030505@marino.st (view raw or flat)
Thread:
Lists: pgsql-bugs
On 10/7/2012 18:36, Tom Lane wrote:
>> >  DragonFly has zlib 1.27 as a base library.  I noticed several zlib warnings
>> >  when pgsql 9.1.6 was being built with gcc47.  The various utilities in
>> >  src/bin are using the zlib.h header incorrectly.
> This issue is dealt with in 9.2.  I don't think we are going to change
> it in previous release branches, because these are only warnings no?
>
> 			regards, tom lane


It successfully completes the build.  I don't know if the warnings are 
harmless or not.  I would have thought the 9.2 fix would have been 
backported to something as recent as version 9.1.x though especially 
since 9.1 is the default version for pgsql in pkgsrc.  If everyone is 
sure that these warnings are harmless, I suppose its okay to live with them.

Thanks,
John


In response to

Responses

pgsql-bugs by date

Next:From: Tom LaneDate: 2012-10-07 17:35:38
Subject: Re: BUG #7588: pgsql 9.1 incompatible with zlib 1.27
Previous:From: Tom LaneDate: 2012-10-07 17:06:43
Subject: Re: BUG #7586: PL/Perl problem

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group