Skip site navigation (1) Skip section navigation (2)

Got it! Re: cygserver fails with "failed to create named pipe,fatal error on IPC transport"

From: David Riggs <dariggs(at)nichibun(dot)ac(dot)jp>
To: pgsql-cygwin(at)postgresql(dot)org
Subject: Got it! Re: cygserver fails with "failed to create named pipe,fatal error on IPC transport"
Date: 2004-07-06 07:38:42
Message-ID: 5.1.1.8.2.20040706163122.03b71908@aoba2.nichibun.ac.jp (view raw or flat)
Thread:
Lists: pgsql-cygwin
The problem was that I double started cygserver, which cause it to lock up, 
I guess.

The point is, when you run the cygserver-install script, it puts an entry 
in Start->control panel->Administrative functions->Services, and so 
apparently when you start up Cygwin, it automatically starts cygserver.

Not realizing this, I started cygserver manually, which claimed that it had 
failed, but actually did not shut down, so there were two processes 
running. Anyway, if I just start postmaster it works.


Thanks Mike and others. I think I got it now. On to the database matters!!

David

Kyoto





At PM 11:44 07/01/04 -0500, you wrote:
>A much easier way to start services, stop services, or see if they are
>running etc. under XP Pro is to do Start->control panel->Administrative
>functions->Services.  Cygwin Cygserver should be in the list and so
>should postmaster.
>
>Did you run the one time configuration script for cygserver?
>
>
>On Thu, 2004-07-01 at 02:23, David Riggs wrote:
> > Dear List,
> >
> > Thanks to earlier help from you all, I went back and installed the proper
> > cygserver for the new 7.4.3. But I cannot get it to run. I see in the
> > README that :
> >
> > ""On Windows NT/2000/XP or 2003, you should always run Cygserver as a
> >    service under LocalSystem account.  This is the way it is installed
> >    for you by the /usr/bin/cygserver-config script."
> >
> > I am running WinXP Pro. But I do not know how to do this (sorry, a real
> > Windows beginner), could someone please talk me through it? I presume this
> > is the cause of the failure described below.
> >
> > Thanks very much,
> >
> > David
> >
> > ps,
> >
> > I have been through the readme for cygserver and postgresql install and
> > checked permissions and added both CYGWIN and CYGSERVER to Windows system
> > environment variable with value of server. If I just try to start up 
> cygserver:
> >
> > $cygserver  <i.e. started with no parameters>
> > cygserver: Initialization complete.  Waiting for requests.
> > cygserver: failed to create named pipe: is the daemon already running?
> > cygserver: fatal error on IPC transport: closing down"
> >
> >
> > ---------------------------(end of broadcast)---------------------------
> > TIP 8: explain analyze is your friend


In response to

pgsql-cygwin by date

Next:From: K-SudhakaranDate: 2004-07-06 11:30:43
Subject: Problem running psql on win32 - reg.
Previous:From: mike gDate: 2004-07-06 02:54:40
Subject: Re: initdb fails with invalid argument to shmat

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group