Skip site navigation (1) Skip section navigation (2)

Re: close-but-not-quite w/ pgadmin3.app on osx 10.3.8

From: OpenMacNews <OpenMacNews(at)speakeasy(dot)net>
To: pgadmin-hackers <pgadmin-hackers(at)postgresql(dot)org>
Cc: "Florian G(dot) Pflug" <fgp(at)phlo(dot)org>,Dave Page <dpage(at)vale-housing(dot)co(dot)uk>
Subject: Re: close-but-not-quite w/ pgadmin3.app on osx 10.3.8
Date: 2005-04-11 14:55:41
Message-ID: 4F927B7B38E7CD3A7490ACE2@tiedgar (view raw or flat)
Thread:
Lists: pgadmin-hackers
hi florian & dave,

-- On April 11, 2005 11:29:09 AM +0200  "Florian G. Pflug" <fgp(at)phlo(dot)org> wrote:

> Hm... prefix shouldn't be needed when using "--enable-appbundle".
> If you specify "--enable-appebundle", all File necessary
> for running pgadmin3 should be installed into the .app.

ok. clear.

>> % cd /usr/ports/pgadmin3-cvs/PgAdminIII.app/Contents/MacOS
>> % otool -L pgadmin3
> Heres the problem - the executable should be named PgAdminIII, not
> pgadminIII.

good gork, man!  i would have been "old(er) & gray(er)" b4 figuring that out ;-D

> I forgot to include my modifications to src/Makefile.am
> in the patch on www.phlo.org - I created a second patch, named
> pgadmin3-bundle-2.diff - please apply this one two, and retry.
>
> (It should be sufficient to just do "make install" again, after
> applying the patch).

i'd just rebuilt without the enable-app <sigh> so i'll re-do here in a minute 
...

> Hm... we could do that - but .app bundles are designed to be relocateable
> anyway, so just move it to wherever you want it to be ;-)

true & fair point.

-- On April 11, 2005 10:43:06 AM +0100  Dave Page <dpage(at)vale-housing(dot)co(dot)uk> 
wrote:

>> Heres the problem - the executable should be named PgAdminIII, not
>
> Don't mess with the branding!! :-)
>
> Can that be made 'pgAdmin3' please? The long form is 'pgAdmin III', with
> the space. Never an uppercase P though.

hey!  who let the marketing guy in here ?!  ;-P


-- On April 11, 2005 2:18:00 PM +0200  "Florian G. Pflug" <fgp(at)phlo(dot)org> wrote:

> I can do that, but first I'd like to know if the current patch + my addition
> from today makes things work for OpenMacNews. If this works, I'll prepare
> a new Version of the patch with the bundle renamed. If not, I'd like to fix
> all remaining problems before introducing new breakage by renaming things...

i'll let you know as soon as the build finishes in a bit .... ( i WANT a DP 
G5!!)

cheers,

richard

In response to

pgadmin-hackers by date

Next:From: Stefan CsomorDate: 2005-04-11 15:47:30
Subject: Re: [wx-dev] Re: OSX Status / Old friend font inheritance...
Previous:From: Dave PageDate: 2005-04-11 13:50:59
Subject: Re: close-but-not-quite w/ pgadmin3.app on osx 10.3.8

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group