Skip site navigation (1) Skip section navigation (2)

yum repo issue

From: John R Pierce <pierce(at)hogranch(dot)com>
To: PostgreSQL <pgsql-general(at)postgresql(dot)org>
Subject: yum repo issue
Date: 2012-04-21 08:29:01
Message-ID: 4F926FCD.10902@hogranch.com (view raw or flat)
Thread:
Lists: pgsql-general
I tried installing 9.1 from the yum repo on a brand new minimal CentOS 
6.1 x86_64 install and got an error.

http://pgsql.privatepaste.com/04289a269b

[root(at)svfis-sg2 ~]# rpm -Uvh pgdg-centos91-9.1-4.noarch.rpm warning: 
pgdg-centos91-9.1-4.noarch.rpm: Header V4 DSA/SHA1 Signature, key ID 
442df0f8: NOKEY Preparing... ########################################### 
[100%] 1:pgdg-centos91 ########################################### 
[100%] [root(at)svfis-sg2 ~]# yum install postgresql91\* Loaded plugins: 
fastestmirror Loading mirror speeds from cached hostfile * base: 
mirror.san.fastserv.com * extras: mirrors.ecvps.com * updates: 
mirror.raystedman.net Setting up Install Process Resolving Dependencies 
--> Running transaction check ---> Package postgresql91.x86_64 
0:9.1.3-1PGDG.rhel6 will be installed ---> Package 
postgresql91-contrib.x86_64 0:9.1.3-1PGDG.rhel6 will be installed --> 
Processing Dependency: libxslt.so.1(LIBXML2_1.0.11)(64bit) for package: 
postgresql91-contrib-9.1.3-1PGDG.rhel6.x86_64 --> Processing Dependency: 
libxslt.so.1(LIBXML2_1.0.18)(64bit) for package: 
postgresql91-contrib-9.1.3-1PGDG.rhel6.x86_64 --> Processing Dependency: 
libxslt.so.1()(64bit) for package: 
postgresql91-contrib-9.1.3-1PGDG.rhel6.x86_64 --> Processing Dependency: 
libossp-uuid.so.16()(64bit) for package: 
postgresql91-contrib-9.1.3-1PGDG.rhel6.x86_64 ---> Package 
postgresql91-debuginfo.x86_64 0:9.1.3-1PGDG.rhel6 will be installed ---> 
Package postgresql91-devel.x86_64 0:9.1.3-1PGDG.rhel6 will be installed 
---> Package postgresql91-docs.x86_64 0:9.1.3-1PGDG.rhel6 will be 
installed ---> Package postgresql91-jdbc.x86_64 0:9.1.901-1PGDG.rhel6 
will be installed --> Processing Dependency: /usr/bin/rebuild-gcj-db for 
package: postgresql91-jdbc-9.1.901-1PGDG.rhel6.x86_64 --> Processing 
Dependency: /usr/bin/rebuild-gcj-db for package: 
postgresql91-jdbc-9.1.901-1PGDG.rhel6.x86_64 --> Processing Dependency: 
libgcj_bc.so.1()(64bit) for package: 
postgresql91-jdbc-9.1.901-1PGDG.rhel6.x86_64 ---> Package 
postgresql91-jdbc-debuginfo.x86_64 0:9.1.901-1PGDG.rhel6 will be 
installed ---> Package postgresql91-libs.x86_64 0:9.1.3-1PGDG.rhel6 will 
be installed ---> Package postgresql91-odbc.x86_64 
0:09.00.0310-1PGDG.rhel6 will be installed --> Processing Dependency: 
libodbcinst.so.2()(64bit) for package: 
postgresql91-odbc-09.00.0310-1PGDG.rhel6.x86_64 --> Processing 
Dependency: libodbc.so.2()(64bit) for package: 
postgresql91-odbc-09.00.0310-1PGDG.rhel6.x86_64 ---> Package 
postgresql91-odbc-debuginfo.x86_64 0:09.00.0310-1PGDG.rhel6 will be 
installed ---> Package postgresql91-plperl.x86_64 0:9.1.3-1PGDG.rhel6 
will be installed ---> Package postgresql91-plpython.x86_64 
0:9.1.3-1PGDG.rhel6 will be installed ---> Package 
postgresql91-pltcl.x86_64 0:9.1.3-1PGDG.rhel6 will be installed --> 
Processing Dependency: libtcl8.5.so()(64bit) for package: 
postgresql91-pltcl-9.1.3-1PGDG.rhel6.x86_64 ---> Package 
postgresql91-python.x86_64 0:4.0-2PGDG.rhel6 will be installed --> 
Processing Dependency: mx for package: 
postgresql91-python-4.0-2PGDG.rhel6.x86_64 ---> Package 
postgresql91-python-debuginfo.x86_64 0:4.0-2PGDG.rhel6 will be installed 
---> Package postgresql91-server.x86_64 0:9.1.3-1PGDG.rhel6 will be 
installed ---> Package postgresql91-tcl.x86_64 0:1.9.0-1.rhel6 will be 
installed ---> Package postgresql91-tcl-debuginfo.x86_64 0:1.9.0-1.rhel6 
will be installed ---> Package postgresql91-test.x86_64 
0:9.1.3-1PGDG.rhel6 will be installed --> Running transaction check ---> 
Package java-1.5.0-gcj.x86_64 0:1.5.0.0-29.1.el6 will be installed 
base/filelists_db | 5.8 MB 00:04 extras/filelists_db | 2.7 kB 00:00 
pgdg91/filelists_db | 139 kB 00:00 updates/filelists_db | 2.1 MB 00:00 
--> Processing Dependency: jpackage-utils >= 1.7.3 for package: 
java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64 --> Processing Dependency: 
sinjdoc for package: java-1.5.0-gcj-1.5.0.0-29.1.el6.x86_64 ---> Package 
libgcj.x86_64 0:4.4.6-3.el6 will be installed --> Processing Dependency: 
libart_lgpl >= 2.1.0 for package: libgcj-4.4.6-3.el6.x86_64 --> 
Processing Dependency: zip >= 2.1 for package: libgcj-4.4.6-3.el6.x86_64 
--> Processing Dependency: gtk2 >= 2.4.0 for package: 
libgcj-4.4.6-3.el6.x86_64 --> Processing Dependency: 
libasound.so.2(ALSA_0.9)(64bit) for package: libgcj-4.4.6-3.el6.x86_64 
--> Processing Dependency: libXrandr.so.2()(64bit) for package: 
libgcj-4.4.6-3.el6.x86_64 --> Processing Dependency: 
libpangocairo-1.0.so.0()(64bit) for package: libgcj-4.4.6-3.el6.x86_64 
--> Processing Dependency: libfontconfig.so.1()(64bit) for package: 
libgcj-4.4.6-3.el6.x86_64 --> Processing Dependency: 
libgtk-x11-2.0.so.0()(64bit) for package: libgcj-4.4.6-3.el6.x86_64 --> 
Processing Dependency: libICE.so.6()(64bit) for package: 
libgcj-4.4.6-3.el6.x86_64 --> Processing Dependency: 
libpangoft2-1.0.so.0()(64bit) for package: libgcj-4.4.6-3.el6.x86_64 --> 
Processing Dependency: libfreetype.so.6()(64bit) for package: 
libgcj-4.4.6-3.el6.x86_64 --> Processing Dependency: 
libcairo.so.2()(64bit) for package: libgcj-4.4.6-3.el6.x86_64 --> 
Processing Dependency: libXtst.so.6()(64bit) for package: 
libgcj-4.4.6-3.el6.x86_64 --> Processing Dependency: 
libpango-1.0.so.0()(64bit) for package: libgcj-4.4.6-3.el6.x86_64 --> 
Processing Dependency: libXrender.so.1()(64bit) for package: 
libgcj-4.4.6-3.el6.x86_64 --> Processing Dependency: 
libgdk_pixbuf-2.0.so.0()(64bit) for package: libgcj-4.4.6-3.el6.x86_64 
--> Processing Dependency: libasound.so.2()(64bit) for package: 
libgcj-4.4.6-3.el6.x86_64 --> Processing Dependency: 
libatk-1.0.so.0()(64bit) for package: libgcj-4.4.6-3.el6.x86_64 --> 
Processing Dependency: libgdk-x11-2.0.so.0()(64bit) for package: 
libgcj-4.4.6-3.el6.x86_64 --> Processing Dependency: libSM.so.6()(64bit) 
for package: libgcj-4.4.6-3.el6.x86_64 ---> Package libxslt.x86_64 
0:1.1.26-2.el6 will be installed ---> Package postgresql91-python.x86_64 
0:4.0-2PGDG.rhel6 will be installed --> Processing Dependency: mx for 
package: postgresql91-python-4.0-2PGDG.rhel6.x86_64 ---> Package 
tcl.x86_64 1:8.5.7-6.el6 will be installed ---> Package unixODBC.x86_64 
0:2.2.14-11.el6 will be installed --> Processing Dependency: 
libltdl.so.7()(64bit) for package: unixODBC-2.2.14-11.el6.x86_64 ---> 
Package uuid.x86_64 0:1.6.1-10.el6 will be installed --> Running 
transaction check ---> Package alsa-lib.x86_64 0:1.0.22-3.el6 will be 
installed ---> Package atk.x86_64 0:1.28.0-2.el6 will be installed ---> 
Package cairo.x86_64 0:1.8.8-3.1.el6 will be installed --> Processing 
Dependency: libpng12.so.0(PNG12_0)(64bit) for package: 
cairo-1.8.8-3.1.el6.x86_64 --> Processing Dependency: 
libpixman-1.so.0()(64bit) for package: cairo-1.8.8-3.1.el6.x86_64 --> 
Processing Dependency: libX11.so.6()(64bit) for package: 
cairo-1.8.8-3.1.el6.x86_64 --> Processing Dependency: 
libpng12.so.0()(64bit) for package: cairo-1.8.8-3.1.el6.x86_64 ---> 
Package fontconfig.x86_64 0:2.8.0-3.el6 will be installed ---> Package 
freetype.x86_64 0:2.3.11-6.el6_2.9 will be installed ---> Package 
gtk2.x86_64 0:2.18.9-6.el6.centos will be installed --> Processing 
Dependency: libtiff >= 3.6.1 for package: 
gtk2-2.18.9-6.el6.centos.x86_64 --> Processing Dependency: 
hicolor-icon-theme for package: gtk2-2.18.9-6.el6.centos.x86_64 --> 
Processing Dependency: libjasper.so.1()(64bit) for package: 
gtk2-2.18.9-6.el6.centos.x86_64 --> Processing Dependency: 
libXcomposite.so.1()(64bit) for package: gtk2-2.18.9-6.el6.centos.x86_64 
--> Processing Dependency: libXinerama.so.1()(64bit) for package: 
gtk2-2.18.9-6.el6.centos.x86_64 --> Processing Dependency: 
libXdamage.so.1()(64bit) for package: gtk2-2.18.9-6.el6.centos.x86_64 
--> Processing Dependency: libXfixes.so.3()(64bit) for package: 
gtk2-2.18.9-6.el6.centos.x86_64 --> Processing Dependency: 
libcups.so.2()(64bit) for package: gtk2-2.18.9-6.el6.centos.x86_64 --> 
Processing Dependency: libXi.so.6()(64bit) for package: 
gtk2-2.18.9-6.el6.centos.x86_64 --> Processing Dependency: 
libXext.so.6()(64bit) for package: gtk2-2.18.9-6.el6.centos.x86_64 --> 
Processing Dependency: libXcursor.so.1()(64bit) for package: 
gtk2-2.18.9-6.el6.centos.x86_64 --> Processing Dependency: 
libtiff.so.3()(64bit) for package: gtk2-2.18.9-6.el6.centos.x86_64 --> 
Processing Dependency: libjpeg.so.62()(64bit) for package: 
gtk2-2.18.9-6.el6.centos.x86_64 ---> Package jpackage-utils.noarch 
0:1.7.5-3.12.el6 will be installed ---> Package libICE.x86_64 
0:1.0.6-1.el6 will be installed ---> Package libSM.x86_64 
0:1.1.0-7.1.el6 will be installed ---> Package libXrandr.x86_64 
0:1.3.0-4.el6 will be installed ---> Package libXrender.x86_64 
0:0.9.5-1.el6 will be installed ---> Package libXtst.x86_64 
0:1.0.99.2-3.el6 will be installed ---> Package libart_lgpl.x86_64 
0:2.3.20-5.1.el6 will be installed ---> Package libtool-ltdl.x86_64 
0:2.2.6-15.5.el6 will be installed ---> Package pango.x86_64 
0:1.28.1-3.el6_0.5.1.centos will be installed --> Processing Dependency: 
libthai >= 0.1.9 for package: pango-1.28.1-3.el6_0.5.1.centos.x86_64 --> 
Processing Dependency: libthai.so.0(LIBTHAI_0.1)(64bit) for package: 
pango-1.28.1-3.el6_0.5.1.centos.x86_64 --> Processing Dependency: 
libthai.so.0()(64bit) for package: 
pango-1.28.1-3.el6_0.5.1.centos.x86_64 --> Processing Dependency: 
libXft.so.2()(64bit) for package: pango-1.28.1-3.el6_0.5.1.centos.x86_64 
---> Package postgresql91-python.x86_64 0:4.0-2PGDG.rhel6 will be 
installed --> Processing Dependency: mx for package: 
postgresql91-python-4.0-2PGDG.rhel6.x86_64 ---> Package sinjdoc.x86_64 
0:0.5-9.1.el6 will be installed --> Processing Dependency: java_cup >= 
0.10 for package: sinjdoc-0.5-9.1.el6.x86_64 ---> Package zip.x86_64 
0:3.0-1.el6 will be installed --> Running transaction check ---> Package 
cups-libs.x86_64 1:1.4.2-44.el6_2.3 will be installed --> Processing 
Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: 
1:cups-libs-1.4.2-44.el6_2.3.x86_64 --> Processing Dependency: 
libavahi-client.so.3()(64bit) for package: 
1:cups-libs-1.4.2-44.el6_2.3.x86_64 --> Processing Dependency: 
libavahi-common.so.3()(64bit) for package: 
1:cups-libs-1.4.2-44.el6_2.3.x86_64 --> Processing Dependency: 
libgnutls.so.26()(64bit) for package: 
1:cups-libs-1.4.2-44.el6_2.3.x86_64 ---> Package 
hicolor-icon-theme.noarch 0:0.11-1.1.el6 will be installed ---> Package 
jasper-libs.x86_64 0:1.900.1-15.el6_1.1 will be installed ---> Package 
java_cup.x86_64 1:0.10k-5.el6 will be installed ---> Package 
libX11.x86_64 0:1.3-2.el6 will be installed --> Processing Dependency: 
libX11-common = 1.3-2.el6 for package: libX11-1.3-2.el6.x86_64 --> 
Processing Dependency: libxcb.so.1()(64bit) for package: 
libX11-1.3-2.el6.x86_64 ---> Package libXcomposite.x86_64 0:0.4.1-2.el6 
will be installed ---> Package libXcursor.x86_64 0:1.1.10-2.el6 will be 
installed ---> Package libXdamage.x86_64 0:1.1.2-1.el6 will be installed 
---> Package libXext.x86_64 0:1.1-3.el6 will be installed ---> Package 
libXfixes.x86_64 0:4.0.4-1.el6 will be installed ---> Package 
libXft.x86_64 0:2.1.13-4.1.el6 will be installed ---> Package 
libXi.x86_64 0:1.3-3.el6 will be installed ---> Package 
libXinerama.x86_64 0:1.1-1.el6 will be installed ---> Package 
libjpeg.x86_64 0:6b-46.el6 will be installed ---> Package libpng.x86_64 
2:1.2.48-1.el6_2 will be installed ---> Package libthai.x86_64 
0:0.1.12-3.el6 will be installed ---> Package libtiff.x86_64 
0:3.9.4-5.el6_2 will be installed ---> Package pixman.x86_64 
0:0.18.4-1.el6_0.1 will be installed ---> Package 
postgresql91-python.x86_64 0:4.0-2PGDG.rhel6 will be installed --> 
Processing Dependency: mx for package: 
postgresql91-python-4.0-2PGDG.rhel6.x86_64 --> Running transaction check 
---> Package avahi-libs.x86_64 0:0.6.25-11.el6 will be installed ---> 
Package gnutls.x86_64 0:2.8.5-4.el6_2.2 will be installed --> Processing 
Dependency: libtasn1.so.3(LIBTASN1_0_3)(64bit) for package: 
gnutls-2.8.5-4.el6_2.2.x86_64 --> Processing Dependency: 
libtasn1.so.3()(64bit) for package: gnutls-2.8.5-4.el6_2.2.x86_64 ---> 
Package libX11-common.noarch 0:1.3-2.el6 will be installed ---> Package 
libxcb.x86_64 0:1.5-1.el6 will be installed --> Processing Dependency: 
libXau.so.6()(64bit) for package: libxcb-1.5-1.el6.x86_64 ---> Package 
postgresql91-python.x86_64 0:4.0-2PGDG.rhel6 will be installed --> 
Processing Dependency: mx for package: 
postgresql91-python-4.0-2PGDG.rhel6.x86_64 --> Running transaction check 
---> Package libXau.x86_64 0:1.0.5-1.el6 will be installed ---> Package 
libtasn1.x86_64 0:2.3-3.el6_2.1 will be installed ---> Package 
postgresql91-python.x86_64 0:4.0-2PGDG.rhel6 will be installed --> 
Processing Dependency: mx for package: 
postgresql91-python-4.0-2PGDG.rhel6.x86_64 --> Finished Dependency 
Resolution Error: Package: postgresql91-python-4.0-2PGDG.rhel6.x86_64 
(pgdg91) Requires: mx You could try using --skip-broken to work around 
the problem You could try running: rpm -Va --nofiles --nodigest

-- 
john r pierce                            N 37, W 122
santa cruz ca                         mid-left coast


Responses

pgsql-general by date

Next:From: Andres FreundDate: 2012-04-21 09:59:07
Subject: Re: Problem with reading data from standby server ?
Previous:From: CondorDate: 2012-04-21 05:28:59
Subject: Re: Problem with reading data from standby server ?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group