Skip site navigation (1) Skip section navigation (2)

Fwd: Invalid version while creating PostgreSQL 9.1 cluster

From: Виктор Столбин <viktor(dot)stolbin(at)gmail(dot)com>
To: pgsql-cluster-hackers(at)postgresql(dot)org, pgsql-pkg-debian(at)postgresql(dot)org, pgsql-admin(at)postgresql(dot)org
Subject: Fwd: Invalid version while creating PostgreSQL 9.1 cluster
Date: 2011-09-23 12:38:00
Message-ID: 4E7C7DA8.6060809@gmail.com (view raw or flat)
Thread:
Lists: pgsql-adminpgsql-cluster-hackerspgsql-pkg-debian
Hello!
I'm trying create a cluster with existing data directory on Debian 
2.6.26-2-686-bigmem. I use PostgreSQL 8.3 installed from apt-get and 
PostgreSQL 9.1 installed from 
[OpenSCG](http://www.openscg.org/se/oscg_download.jsp?file=packages/postgres-9.1.0-1.i386.openscg.deb&user=) 
I want to create cluster with existing data directory and add it to 
postgresql-commons using command:

pg_createcluster -d /opt/postgres/9.1/data/ -e UTF8 --locale ru_Ru -p 
6432 9.1 MAIN_RU

The result is:

Error: invalid version: 9.1

I found this question 
http://serverfault.com/questions/288612/cant-create-clusters-in-postgresql-9-0 
but it seems in my case the problem is in postresql-commons package or 
in PostgreSQL 9.1 package that is installed.

aptitude show postgresql-common
Package: postgresql-common
New: yes
State: installed
Automatically installed: yes
Version: 94lenny1
Priority: optional
Section: misc
Maintainer: Martin Pitt <mpitt(at)debian(dot)org>
Uncompressed Size: 496k
Depends: postgresql-client-common (>= 94lenny1), procps, adduser,
debconf (>=
0.5.00) | debconf-2.0, lsb-base (>= 3.0-3)
Recommends: ssl-cert (>= 1.0.11)
Conflicts: postgresql (< 7.5), postgresql-7.4 (< 1:7.4.8-10),
postgresql-8.0 (<
8.0.3-7), postgresql-client (< 7.5)
Replaces: postgresql (< 7.5), postgresql-client (< 7.5)


Update.

I check this on Ubuntu 2.6.32-24-generic #39 with same deb packages, the 
problem is the same. I think it's in postgresql-commons facilities 
packaged in OpenSCG deb. PostgreSQL 9.1 is released 2011-09-11.

Any help would be appreciated!

Best Regurds,
Viktor Stolbin
Grffolabs LTD


Responses

pgsql-pkg-debian by date

Next:From: Hannu KrosingDate: 2011-09-23 18:26:41
Subject: Re: [pgsql-cluster-hackers] Fwd: Invalid version while creating PostgreSQL 9.1 cluster
Previous:From: Виктор СтолбинDate: 2011-09-23 11:53:57
Subject: Invalid version while creating PostgreSQL 9.1 cluster

pgsql-cluster-hackers by date

Next:From: Hannu KrosingDate: 2011-09-23 18:26:41
Subject: Re: [pgsql-cluster-hackers] Fwd: Invalid version while creating PostgreSQL 9.1 cluster
Previous:From: Fabricio MotaDate: 2011-09-10 01:43:31
Subject: Re: Hi all!

pgsql-admin by date

Next:From: Hannu KrosingDate: 2011-09-23 18:26:41
Subject: Re: [pgsql-cluster-hackers] Fwd: Invalid version while creating PostgreSQL 9.1 cluster
Previous:From: c kDate: 2011-09-23 11:42:43
Subject: Re: [GENERAL] Date time value error in Ms Access using pass through queries

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group