Skip site navigation (1) Skip section navigation (2)

Re: problem with 09.0.0200

From: Hiroshi Inoue <inoue(at)tpf(dot)co(dot)jp>
To: Andreas <maps(dot)on(at)gmx(dot)net>
Cc: pgsql-odbc(at)postgresql(dot)org
Subject: Re: problem with 09.0.0200
Date: 2011-04-13 03:24:42
Message-ID: 4DA5177A.1070604@tpf.co.jp (view raw or flat)
Thread:
Lists: pgsql-odbc
Hi Andreas,

(2011/04/13 12:02), Andreas wrote:
> Hi,
> I just upgraded some LAN PCs from the last 0.8.04 to 09.0.0200 after a
> longer testing period on my own box.
> Now a user complaines that he couldn't login anymore with MS-Access.
> Dropping back to the last 08-driver cleared the issue.
>
> The problem is a "%" character within the password.
> Passwords without % do work OK. There might be other signes hat won't
> work though.

Maybe % is treated as an escape character.
Could you please try %% instead of %?

regards,
Hiroshi Inoue

> Is this an error in my connection string or should it rather be minded
> somewhere in the driver?
>
> Generally I'm freightend that there is a deeper problem that just shows
> here for now and hides elsewhere to kick me later so I went back to
> 0.8... for the time beeing.
>
> Is there someone that could shed some light on this?


In response to

pgsql-odbc by date

Next:From: RaifordDate: 2011-04-13 12:09:25
Subject: BYTEA Fields and Memory Consumption
Previous:From: AndreasDate: 2011-04-13 03:02:07
Subject: problem with 09.0.0200

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group