Skip site navigation (1) Skip section navigation (2)

Re: Access Autonumber fields not detected in 9.0.0200

From: Hiroshi Inoue <inoue(at)tpf(dot)co(dot)jp>
To: pgsql-odbc(at)postgresql(dot)org
Subject: Re: Access Autonumber fields not detected in 9.0.0200
Date: 2011-03-04 08:49:20
Message-ID: 4D70A790.6030108@tpf.co.jp (view raw or flat)
Thread:
Lists: pgsql-odbc
Hi Arnaud,

(2011/03/03 20:16), Arnaud Lesauvage wrote:
> Hi all !
>
> We are linking PostgreSQL tables (server version 8.4) into Access 2000.
> I tried upgrading our psqlodbc driver from 8.03.0400 to 9.00.0200, but
> the autonumber fields (converted from serial fields) are not detected

Didn't you drop the *not null* attribute from the fields?

regards,
Hiroshi Inoue

> anymore.
> The connection string is the same (i.e. there is still the "0x2" extra
> option to detect serial as autonumber).
>
> I have pasted the debug log of the psqlodbc 9.00.0200 driver trying to
> link the table (and failing to detect autonumber) here :
> http://pastebin.com/aVRWFyJd
>
> If you need any other information, I can do some testing.
>
> Thanks a lot for your help !
>
> Regards,
> Arnaud Lesauvage


In response to

Responses

pgsql-odbc by date

Next:From: Arnaud LesauvageDate: 2011-03-04 09:18:42
Subject: Re: Access Autonumber fields not detected in 9.0.0200
Previous:From: Arnaud LesauvageDate: 2011-03-03 11:16:30
Subject: Access Autonumber fields not detected in 9.0.0200

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group