Skip site navigation (1) Skip section navigation (2)

Re: pg_upgrade fails for non-postgres user

From: Josh Berkus <josh(at)agliodbs(dot)com>
To: Magnus Hagander <magnus(at)hagander(dot)net>
Cc: PostgreSQL-development <pgsql-hackers(at)postgresql(dot)org>
Subject: Re: pg_upgrade fails for non-postgres user
Date: 2011-01-28 22:49:21
Message-ID: 4D4347F1.8080502@agliodbs.com (view raw or flat)
Thread:
Lists: pgsql-hackers
> When that was fixed, I realized the psql command to create the
> datanbases connect to database "template1" only to immediately switch
> to database "postgres", which also seems rather pointless.
> 
> Attach patch makes it connect to the "postgres" database instead of
> $USER, and then also changes the psql command to actually use it.

Hmmmm ... shouldn't we connect to template1?  The database "postgres" is
reasonably likely to be dropped, whereas template1 doesn't get touched
usually.

-- 
                                  -- Josh Berkus
                                     PostgreSQL Experts Inc.
                                     http://www.pgexperts.com

In response to

Responses

pgsql-hackers by date

Next:From: Andrew DunstanDate: 2011-01-28 22:58:56
Subject: Re: mingw format warnings
Previous:From: Andrew DunstanDate: 2011-01-28 22:35:14
Subject: Re: mingw format warnings

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group