Skip site navigation (1) Skip section navigation (2)

Re: problem connecting via ODBC when unicode (now in correct forum.).

From: Adrian Klaver <adrian(dot)klaver(at)gmail(dot)com>
To: Kim Mortensen <kimfmx(at)gmail(dot)com>
Cc: Hiroshi Saito <hiroshi(at)winpg(dot)jp>, pgsql-odbc(at)postgresql(dot)org
Subject: Re: problem connecting via ODBC when unicode (now in correct forum.).
Date: 2011-01-21 21:13:28
Message-ID: 4D39F6F8.3080700@gmail.com (view raw or flat)
Thread:
Lists: pgsql-odbc
On 01/21/2011 12:35 PM, Kim Mortensen wrote:
> Adrian,
>
> Tje letters you are typing are from Danish, but any will do.
>
> Now im working abit from memory, but when the databse is build, initdb
> is using UNICODE as encoding, "C" for locale, so it should be
> independant of the locale settings.

I believe the problem, as Hiroshi Saito pointed out, is that the client 
encoding is being set on Windows before the connection is attempted and 
that it is picking the wrong one. Per his post pgAdmin and JDBC are 
probably just starting with UTF8 and that is why they succeed. At this 
point I don't know how to get around that.

>
> Best Regards
> Kim Mortensen


-- 
Adrian Klaver
adrian(dot)klaver(at)gmail(dot)com

In response to

Responses

pgsql-odbc by date

Next:From: Kim MortensenDate: 2011-01-21 21:28:43
Subject: Re: problem connecting via ODBC when unicode (now in correct forum.).
Previous:From: Kim MortensenDate: 2011-01-21 20:35:41
Subject: Re: problem connecting via ODBC when unicode (now in correct forum.).

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group