Skip site navigation (1) Skip section navigation (2)

Re: Configure/Build 9.0 rc1 - cannot build against python3.1, with two versions of python in the environment

From: Josh Berkus <josh(at)agliodbs(dot)com>
To: James William Pye <lists(at)jwp(dot)name>
Cc: pgsql-testers(at)postgresql(dot)org
Subject: Re: Configure/Build 9.0 rc1 - cannot build against python3.1, with two versions of python in the environment
Date: 2010-09-12 22:23:23
Message-ID: 4C8D52DB.4050408@agliodbs.com (view raw or flat)
Thread:
Lists: pgsql-testers
James,

> On Sep 11, 2010, at 4:11 PM, Josh Berkus wrote:
>> So, is this a bug?  Should we be fixing it before release?
> 
> 
> Yes to both.

Hmmm.  Tom Lane says "pilot error" because there are two versions of
Python in the path.  Specifically:

"In particular, how'd those 3.1 references get in there when the python
version in $PATH is 2.4? It's for damn sure we didn't introduce those."

If Tom is incorrect, please take up the thread on -BUGS.  I don't know
enough about python libs in builds to argue either way.

-- 
                                  -- Josh Berkus
                                     PostgreSQL Experts Inc.
                                     http://www.pgexperts.com

In response to

Responses

pgsql-testers by date

Next:From: Lou PiccianoDate: 2010-09-13 01:20:55
Subject: Re: Configure/Build 9.0 rc1 - cannot build against python3.1, with two versions of python in the environment
Previous:From: Lou PiccianoDate: 2010-09-12 16:53:02
Subject: pg_ctrl: odd messages logged at startup -

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group