Skip site navigation (1) Skip section navigation (2)

[Fwd: Re: [Fwd: [TEST REPORT] StackBuilder installs old JDBC driver (in strange location on 64-bit Windows)]]

From: Josh Berkus <josh(at)agliodbs(dot)com>
To: pgsql-testers(at)postgresql(dot)org
Subject: [Fwd: Re: [Fwd: [TEST REPORT] StackBuilder installs old JDBC driver (in strange location on 64-bit Windows)]]
Date: 2010-09-10 22:20:11
Message-ID: 4C8AAF1B.3090206@agliodbs.com (view raw or flat)
Thread:
Lists: pgsql-testers

-------- Original Message --------
Subject: Re: [Fwd: [TESTERS] [TEST REPORT] StackBuilder installs old
JDBC driver (in strange location on 64-bit Windows)]
Date: Fri, 10 Sep 2010 23:18:45 +0100
From: Dave Page <dpage(at)postgresql(dot)org>
To: Josh Berkus <josh(at)agliodbs(dot)com>

StackBuilder apps are completely independent of the server installer,
though we have been scheduling a set of updates to roughly coincide
with the release. Once the 9.0 JDBC driver is released, it'll be
updated in our next quarterly release cycle though.

On Fri, Sep 10, 2010 at 9:43 PM, Josh Berkus <josh(at)agliodbs(dot)com> wrote:
>
>
> -------- Original Message --------
> Subject:        [TESTERS] [TEST REPORT] StackBuilder installs old JDBC driver
> (in strange location on 64-bit Windows)
> Date:   Fri, 10 Sep 2010 13:32:09 -0700
> From:   Adam Rauch <adam(at)labkey(dot)com>
> To:     pgsql-testers(at)postgresql(dot)org
>
>
>
> [TEST REPORT]
>
>
>
> [Release]: 9.0RC1
>
>
>
> [Test Type]: Install
>
>
>
> [Test]: Installed 64-bit Windows version via the installer and ran Stack
> Builder
>
>
>
> [Platform]: Windows 7 64-Bit
>
>
>
> [Parameters]:
>
>
>
> [Failure]: Yes
>
>
>
> [Results]: Old JDBC drivers, postgresql-8.4-701.jdbc3.jar and
> postgresql-8.4-701.jdbc4.jar, were installed; I expected drivers that
> actually support 9.0.  Also (though less important), while the
> PostgreSQL installer itself defaults to c:\Program Files\PostgreSQL\9.0
> (as expected for a 64-bit program), Stack Builder’s default install
> directory for the JDBC drivers is c:\Program Files
> (x86)\PostgreSQL\pgJDBC.  This is unintuitive and makes the drivers
> difficult to find… I expected them to end up somewhere near my
> PostgreSQL install directory (e.g., c:\Program Files\PostgreSQL\pgJDBC).
>
>
>
> [Comments]: PostgreSQL 9.0 installer needs to ship the 9.0 JDBC drivers
> since the 8.4 JDBC drivers have known incompatibilities with 9.0
> servers.  The drivers currently shipping with RC1 are in fact obsolete
> versions of the 8.4 drivers (702 is the most recent).
>
>
>
>
>
>
> --
>                                  -- Josh Berkus
>                                     PostgreSQL Experts Inc.
>                                     http://www.pgexperts.com
>



-- 
Dave Page
PostgreSQL Core Team
http://www.postgresql.org/


-- 
                                  -- Josh Berkus
                                     PostgreSQL Experts Inc.
                                     http://www.pgexperts.com

pgsql-testers by date

Next:From: Lou PiccianoDate: 2010-09-11 17:12:13
Subject: Configure/Build 9.0 rc1 - cannot build against python3.1, with two versions of python in the environment
Previous:From: Adam RauchDate: 2010-09-10 20:32:09
Subject: [TEST REPORT] StackBuilder installs old JDBC driver (in strange location on 64-bit Windows)

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group