Skip site navigation (1) Skip section navigation (2)

9.0rc1 Solaris binaries on opensolaris

From: Steve Singer <ssinger(at)ca(dot)afilias(dot)info>
To: pgsql-testers(at)postgresql(dot)org
Subject: 9.0rc1 Solaris binaries on opensolaris
Date: 2010-09-03 16:52:00
Message-ID: 4C8127B0.3080102@ca.afilias.info (view raw or flat)
Thread:
Lists: pgsql-testers
[TEST REPORT]
[Release]: 9.0rc1
[Test]: initdb
[Platform]: SunOS opensolaris 5.11 snv_111b i86pc i386 i86pc Solaris
[Failure]:  libssl not found
[Results]


I tried running the pre-built Solaris x86 32 bit binaries on an Solaris 
11 install and they fail with

bin/initdb
ld.so.1: initdb: fatal: libssl.so.0.9.7: open failed: No such file or 
directory
Killed

This version of solaris identifies itself as
uname -a
SunOS opensolaris 5.11 snv_111b i86pc i386 i86pc Solaris

and seems to have libssl.so.0.9.8 installed.

I can't claim to understand Sun branding enough to know if this install 
is this opensolaris Oracle is killing off or an old snapshot release of 
the what will be Solaris 11.

Our README cautions against using the binaries Solaris versions older 
than 10 8/07, we might want to add that it also might not work on newer 
versions.  I also wonder if there are Solaris 10 installs with the newer 
libssl that will have the same issue.






-- 
Steve Singer
Afilias Canada
Data Services Developer
416-673-1142

Responses

pgsql-testers by date

Next:From: Lou PiccianoDate: 2010-09-03 17:08:28
Subject: Re: 9.0rc1 Solaris binaries on opensolaris
Previous:From: Bruce MomjianDate: 2010-08-25 19:40:17
Subject: Re: replication is not working

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group