Skip site navigation (1) Skip section navigation (2)

Re: Issue with libpq < 8.4

From: Guillaume Lelarge <guillaume(at)lelarge(dot)info>
To: Magnus Hagander <magnus(at)hagander(dot)net>
Cc: Dave Page <dpage(at)pgadmin(dot)org>, pgadmin-hackers <pgadmin-hackers(at)postgresql(dot)org>
Subject: Re: Issue with libpq < 8.4
Date: 2010-08-24 11:20:08
Message-ID: 4C73AAE8.7020304@lelarge.info (view raw or flat)
Thread:
Lists: pgadmin-hackers
Le 24/08/2010 13:01, Magnus Hagander a écrit :
> On Tue, Aug 24, 2010 at 12:55 PM, Dave Page <dpage(at)pgadmin(dot)org> wrote:
>> On Tue, Aug 24, 2010 at 11:49 AM, Magnus Hagander <magnus(at)hagander(dot)net>
>> wrote:
>>> This "disqualifies" pgAdmin3 from quite a lot of platforms. There
>>> aren't that many that are on 8.4+ yet :-(
>>
>> If the packagers are willing to update pgAdmin to 1.12, it seems
>> highly likely that they'll also update their PostgreSQL package to
>> 8.4+ too. The distros with a conservative update policy (like Debian
>> Stable) won't update either.
> 
> It's probably going to make it very hard for a backports repository to
> carry it though :( But I guess it could keep a backport of libpq as
> well, since it's always backwards compatible.
> 

Can't we just have it set a variable we could check with a #ifdef? We
don't use PQconninfoParse in many files (actually, two). So it would be
pretty easy to add the #ifdef line, so that it won't be a big issue for
packagers.


-- 
Guillaume
 http://www.postgresql.fr
 http://dalibo.com

In response to

Responses

pgadmin-hackers by date

Next:From: Dave PageDate: 2010-08-24 11:26:51
Subject: Re: Issue with libpq < 8.4
Previous:From: Magnus HaganderDate: 2010-08-24 11:01:56
Subject: Re: Issue with libpq < 8.4

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group