Skip site navigation (1) Skip section navigation (2)

Re: wip: functions median and percentile

From: "Kevin Grittner" <Kevin(dot)Grittner(at)wicourts(dot)gov>
To: "David Fetter" <david(at)fetter(dot)org>, "Robert Haas" <robertmhaas(at)gmail(dot)com>
Cc: "Pavel Stehule" <pavel(dot)stehule(at)gmail(dot)com>, "Greg Stark" <gsstark(at)mit(dot)edu>, "PostgreSQL Hackers" <pgsql-hackers(at)postgresql(dot)org>, "Tom Lane" <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Subject: Re: wip: functions median and percentile
Date: 2010-08-19 17:12:12
Message-ID: 4C6D1F9C020000250003491F@gw.wicourts.gov (view raw or flat)
Thread:
Lists: pgsql-hackerspgsql-rrreviewers
David Fetter <david(at)fetter(dot)org> wrote:
 
> Median may be useful, but we pretty much can't just call it
> "median." Instead, we need to call it something like "left_median"
> or "arithmetic_median."
 
I think it would be reasonable, and perhaps preferable, to use just
"median" for the semantics described in most dictionaries -- for
example, this:
 
http://www.merriam-webster.com/dictionary/median
 
If you do a google search for "median" and poke around, you'll find
many places where this is the only definition mentioned; the others
seem to be rather infrequently used.  Why not make the commone usage
convenient?
 
-Kevin

In response to

Responses

pgsql-hackers by date

Next:From: David FetterDate: 2010-08-19 17:14:58
Subject: Re: wip: functions median and percentile
Previous:From: Heikki LinnakangasDate: 2010-08-19 17:04:09
Subject: Re: CommitFest 2009-07: Yay, Kevin! Thanks, reviewers!

pgsql-rrreviewers by date

Next:From: David FetterDate: 2010-08-19 17:14:58
Subject: Re: wip: functions median and percentile
Previous:From: David FetterDate: 2010-08-19 17:03:20
Subject: Re: wip: functions median and percentile

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group