On 09/06/10 10:21, Simon Riggs wrote:
> On Tue, 2010-06-08 at 18:30 -0400, Andrew Dunstan wrote:
>> I prefer archive_cleanup_command. We should name things after their
>> principal function, not an implementation detail, IMNSHO.
>> More importantly, we should include an example in the docs. I created
>> one the other day when this was actually bothering me a bit (see
>> That seemed to work ok, but maybe it's too long, and maybe people would
>> prefer a shell script to perl.
> I submitted a patch to make the command "pg_standby -a %r"
> That's a more portable solution, ISTM.
> I'll commit that and fix the docs.
Huh, wait. There's no -a option in pg_standby, so I presume you're
planning to add that too. I don't like confusing pg_standby into this,
the docs are currently quite clear that if you want to use the built-in
standby mode, you can't use pg_standby, and this would muddy the waters.
Maybe we could add a new pg_cleanuparchive binary, but we'll need some
In response to
pgsql-hackers by date
|Next:||From: Fujii Masao||Date: 2010-06-10 07:25:07|
|Subject: variable TriggerFile can be declared as static|
|Previous:||From: Heikki Linnakangas||Date: 2010-06-10 07:07:13|
|Subject: Re: InvalidXLogRecPtr in docs|