Skip site navigation (1) Skip section navigation (2)

psycopg2 license changed

From: Federico Di Gregorio <fog(at)initd(dot)org>
To: pgsql-hackers(at)postgresql(dot)org
Subject: psycopg2 license changed
Date: 2010-02-14 01:13:20
Message-ID: 4B774E30.5080800@initd.org (view raw or flat)
Thread:
Lists: pgsql-hackers
Hi *,

I just wanted all interested people know that psycopg2 2.0.14 to be
released in the next few days will be under the LGPL3 + OpenSSL
exception (example code and tests under the LGPL3 alone because they are
never linked to OpenSSL).

The Zope 2 and 3 adapters will be splitted out into their own packages
after next release (i.e., during 2.0.15 development) to facilitate
easy_install, etc., and will be available under LGPL3 or ZPL.

Changes are already available from public git repository:

git://luna.dndg.it/public/psycopg2


I hope this makes everybody happy, have fun,
federico

-- 
Federico Di Gregorio                                       fog(at)initd(dot)org
 Everything will be OK at the end. If it's not OK, it's not the end.
                                                              -- Unknown


Responses

pgsql-hackers by date

Next:From: Robert HaasDate: 2010-02-14 02:36:19
Subject: Re: Re: [COMMITTERS] pgsql: Remove old-style VACUUM FULL (which was known for a little while
Previous:From: Andrew DunstanDate: 2010-02-14 00:38:20
Subject: Re: Package namespace and Safe init cleanup for plperl [PATCH]

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group