Skip site navigation (1) Skip section navigation (2)

Re: Error on Vacuum?

From: "John J(dot) Urbaniak" <jjurban(at)attglobal(dot)net>
To: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: pgsql-novice(at)postgresql(dot)org
Subject: Re: Error on Vacuum?
Date: 2010-01-07 11:13:49
Message-ID: 4B45C1ED.3000800@attglobal.net (view raw or flat)
Thread:
Lists: pgsql-novice
Tom Lane wrote:
> "John J. Urbaniak" <jjurban(at)attglobal(dot)net> writes:
>   
>>> Hm?  Then how did you get as far as having vacuumdb produce that error?
>>>       
>
>   
>> Sorry.  I can start the server, but I can't connect to the database.
>>     
>
> That doesn't make any sense either, unless you have more corruption than
> the previous message indicated.  The error you showed was something that
> would only occur on an attempt to access a user table.
>
> Maybe you have something in a .psqlrc file that is doing something extra
> when you try to connect?
>
> 			regards, tom lane
>
>   
I don't know.  It's strange.  I "start" the database with 
E:\PGSQL\BIN\PG_CTL.EXE "-D E:/PGSData -l logfile start"

I get no error message on the call.

But I notice that there is no postmaster.id file generated.

John

In response to

Responses

pgsql-novice by date

Next:From: Andrew RoseDate: 2010-01-07 11:42:34
Subject: Using TCP load-balancers for read-only connections
Previous:From: Tom LaneDate: 2010-01-07 04:29:28
Subject: Re: Error on Vacuum?

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group