Skip site navigation (1) Skip section navigation (2)

Re: [pgadmin-support] PgAdmin Crash

From: Guillaume Lelarge <guillaume(at)lelarge(dot)info>
To: Franz(dot)Fritsche(at)FernUni-Hagen(dot)de
Cc: "pgadmin-support(at)postgresql(dot)org" <pgadmin-support(at)postgresql(dot)org>, pgadmin-hackers <pgadmin-hackers(at)postgresql(dot)org>
Subject: Re: [pgadmin-support] PgAdmin Crash
Date: 2010-01-05 18:28:07
Message-ID: 4B4384B7.5040804@lelarge.info (view raw or flat)
Thread:
Lists: pgadmin-hackerspgadmin-support
Le 05/01/2010 18:33, Guillaume Lelarge a écrit :
> Le 05/01/2010 17:40, Guillaume Lelarge a écrit :
>> Le 05/01/2010 04:34, Franz Fritsche a écrit :
>>> Dear Guillaume!
>>>
>>> I'm sorry, but I could not figure out how to reply to your post in the mailing list. :-(
>>>  
>>>>> Obviously the problem is that "Properties..." is not disabled (grayed), which it should be. 
>>>>> [... ] The same seems to be true for "Delete/Drop...", though selecting it does 
>>>>> not produce a crash (it just seems to have no effect).
>>>>>
>>>> I have the same behaviour. In fact, you don't need the /q parameter to
>>>> trigger it. I added a ticket for this
>>>
>>> Ah, you are right, just tried it! :-)
>>>
>>> C:\Programme\PostgreSQL\8.4\bin\pgAdmin3.exe /s "PostgreSQL 8.4"
>>>
>>> Found more problems (i.e. another crash) with this startup mode:
>>>
>>> - Tools / Server Status ---> Crash!
>>>
>>> Actually there are lots of differences (concerning the activated/disabled commands in the menu) 
>>> between (a) standard startup and manual connection with the database and (b) startup with 
>>> switch /s (->automatic connection):
>>>
>>> (1) After standard startup and manual connection with database _and then selecting "Server (1)" 
>>> in the Object Browser_ ALL commands in the menu "Tool" are grayed - not so after startup with 
>>> /s.
>>>
>>> (2) After standard startup [etc.] "File / Change Password..." is disabled (grayed) - not so after 
>>> startup with /s. (!)
>>>
>>> (3) After standard startup [etc.] "View / Refresh" is disabled (grayed) - not so after startup with /s.
>>>
>>
>> This only happens on Windows, AFAICT. Problem is that the correct item
>> is not selected. The GUI should show the correct server highlighted. I
>> tried something yesterday but it didn't work out well. Will try once
>> again tonight.
>>
> 
> At last, I found that it has nothing to do with Windows. I suppose you
> unchecked the "restore environment" checkbox for this server, didn't you?
> 
> 

This patch should fix this issue.

Comments?


-- 
Guillaume.
 http://www.postgresqlfr.org
 http://dalibo.com

Attachment: ticket123_v1.patch
Description: text/x-patch (904 bytes)

In response to

pgadmin-hackers by date

Next:From: pgAdmin TracDate: 2010-01-05 18:29:15
Subject: Re: [pgAdmin III] #123: "Properties..." is not disabled (grayed) when it should be.
Previous:From: Guillaume LelargeDate: 2010-01-05 17:33:44
Subject: Re: PgAdmin Crash

pgadmin-support by date

Next:From: Guillaume LelargeDate: 2010-01-05 18:34:15
Subject: Re: PgAdmin Crash
Previous:From: Guillaume LelargeDate: 2010-01-05 17:33:44
Subject: Re: PgAdmin Crash

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group