Skip site navigation (1) Skip section navigation (2)

Re: No me funciona la base de datos

From: María José Gacto <mjgacto(at)ugr(dot)es>
To: Agustin Ignacio Genoves <agustingenoves(at)gmail(dot)com>
Cc: pgsql-es-ayuda(at)postgresql(dot)org
Subject: Re: No me funciona la base de datos
Date: 2009-11-23 18:21:24
Message-ID: 4B0AD2A4.30105@ugr.es (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
Tienes alguna idea de como usar pgresetxlog?
Gracias de nuevo.
Agustin Ignacio Genoves escribió:
> Te paso un par de paginas donde hay algo del tema:
>
> http://forums.theplanet.com/lofiversion/index.php/t52120.html
> http://www.postgresql-es.org/node/293
> http://markmail.org/message/dm5fclmbddbgbmml
>
> yo particularmente probaria pg_resetxlog
> (http://www.postgresql.org/docs/8.3/static/app-pgresetxlog.html)
> pero la verdad que no quisiera estar en tu lugar. Seguire leyendo para
> ver si te puedo dar una mano desde aca, espero que lo soluciones.
>
> El día 23 de noviembre de 2009 15:09, María José Gacto
> <mjgacto(at)ugr(dot)es> escribió:
>   
>> Si hubo un corto de energia. Tengo la versión 8.0.1 de postgres
>> He visto que se podia hacer un standby pero no me atrevo, ni se como
>> hacerlo.
>> ¿Como lo puedo arreglar?
>> Agustin Ignacio Genoves escribió:
>>     
>>> Paso algo antes de que te diera ese error, digo, ¿corte de energia
>>> electrica o algo por el estilo?. Sobre que SO esta corriendo el
>>> postgres. ¿Hiciste chequeo del disco? Tengo entendido que este tipo de
>>> error es grave, y se da cuando hay problemas al grabar la WAL. Alvaro
>>> podra corregirme si me equivoco. ¿Que version de postgres estas
>>> corriendo?
>>>
>>> El día 23 de noviembre de 2009 14:44, María José Gacto
>>> <mjgacto(at)ugr(dot)es> escribió:
>>>
>>>       
>>>> Si me queda espacio. Es más he  echo una copia de la carpeta data por si
>>>> acaso y me queda espacio.
>>>> Gracias por tu rapida respuesta
>>>> Agustin Ignacio Genoves escribió:
>>>>
>>>>         
>>>>> Te queda espacio en el disco donde estan los datos?
>>>>>
>>>>> El día 23 de noviembre de 2009 13:59, María José Gacto
>>>>> <mjgacto(at)ugr(dot)es> escribió:
>>>>>
>>>>>
>>>>>           
>>>>>> Hola a todos:
>>>>>>  Estoy muy preocupada no tengo una copia de seguridad de la base de
>>>>>> datos
>>>>>> y
>>>>>> no me arranca. Además, no se que es lo que tengo que hacer para
>>>>>> solucionarlo. ¿ Alguien me puede ayudar?
>>>>>>  De momento he copiado los ficheros de /data pero no se como
>>>>>> solucionarlo.
>>>>>>
>>>>>> Aqui os envio lo que me sale cuando trato de arrancar la base de datos
>>>>>>
>>>>>> LOG:  database system shutdown was interrupted at 2009-11-23 16:07:24
>>>>>> CET
>>>>>> LOG:  record with zero length at 6/47E67BC0
>>>>>> LOG:  invalid primary checkpoint record
>>>>>> LOG:  record with zero length at 6/47E67B64
>>>>>> LOG:  invalid secondary checkpoint record
>>>>>> PANIC:  could not locate a valid checkpoint record
>>>>>> LOG:  startup process (PID 6185) was terminated by signal 6
>>>>>> LOG:  aborting startup due to startup process failure
>>>>>>
>>>>>> Muchisimas gracias.
>>>>>>  María José
>>>>>> --
>>>>>> TIP 3: Si encontraste la respuesta a tu problema, publícala, otros te
>>>>>> lo
>>>>>> agradecerán
>>>>>>
>>>>>>
>>>>>>
>>>>>>             
>>>>>           
>>>>         
>>>       
>>     
>
>   


In response to

Responses

pgsql-es-ayuda by date

Next:From: Agustin Ignacio GenovesDate: 2009-11-23 18:25:11
Subject: Re: No me funciona la base de datos
Previous:From: Gustavo RossoDate: 2009-11-23 18:21:17
Subject: Re: No me funciona la base de datos

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group