Skip site navigation (1) Skip section navigation (2)

Re: Can't Access Pgsql 7.4.3 in phpPgAdmin on Mac OS X

From: John DeSoi <desoi(at)pgedit(dot)com>
To: Lola Lee <lola(at)his(dot)com>
Cc: pgsql-novice(at)postgresql(dot)org
Subject: Re: Can't Access Pgsql 7.4.3 in phpPgAdmin on Mac OS X
Date: 2004-12-15 20:09:56
Message-ID: 4A6D4FAE-4ED5-11D9-988A-000A95B03262@pgedit.com (view raw or flat)
Thread:
Lists: pgsql-novice
Hi Lola,

On Dec 15, 2004, at 6:31 AM, Lola Lee wrote:

> I am running the latest version of OS X on my PowerBook.  When I try 
> to access my 7.4.3 Postgresql installation (I used the package from 
> entropy.ch), I get this message "Login disallowed for security 
> reasons. ". So, I checked ph_hba.conf and this is how it is set up 
> right now:

This is in the FAQ document in the phpPgAdmin main directory:

Q: For some users I get a "Login disallowed for security" message.

A: Logins via phpPgAdmin with no password or certain usernames (pgsql,
    postgres, root, administrator) are denied by default. Before 
changing this
    behaviour (setting $conf['extra_login_security'] to false in the
    config.inc.php file) please read the PostgreSQL documentation about 
client
    authentication and understand how to change PostgreSQL's pg_hba.conf 
to
    enable passworded local connections.



Best,

John DeSoi, Ph.D.
http://pgedit.com/
Power Tools for PostgreSQL


In response to

Responses

pgsql-novice by date

Next:From: Lola LeeDate: 2004-12-15 20:23:23
Subject: Re: Can't Access Pgsql 7.4.3 in phpPgAdmin on Mac OS X
Previous:From: Ragnar HafstaĆ°Date: 2004-12-15 18:23:43
Subject: Re: [PERFORM] \d output to a file

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group