Tom Lane wrote:
> adunstan(at)postgresql(dot)org (Andrew Dunstan) writes:
>> Log Message:
>> Small stylistic improvement in recent FORCE QUOTE * code - use a bool instead of a magic value.
> This actually broke things a bit. I agree that the original coding with
> a phony list header was horridly ugly, but it did have one redeeming
> value: namely that the various existing tests for force_quote not empty
> still worked as-is. With the separate bool you need to extend all those
> checks. On balance it still seems cleaner that way, though, so I made
> the necessary fixes.
Oops! Thanks. That will teach me to code before I have my coffee.
In response to
pgsql-committers by date
|Next:||From: Tom Lane||Date: 2009-07-25 17:50:19|
|Subject: Re: [COMMITTERS] pgsql: Reserve the shared memory region during backend startup on |
|Previous:||From: Tom Lane||Date: 2009-07-25 17:07:51|
|Subject: Re: pgsql: Small stylistic improvement in recent FORCE QUOTE * code - use a |