Skip site navigation (1) Skip section navigation (2)

Re: Upgrading our minimum required flex version for 8.5

From: Andrew Dunstan <andrew(at)dunslane(dot)net>
To: Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us>
Cc: pgsql-hackers(at)postgreSQL(dot)org
Subject: Re: Upgrading our minimum required flex version for 8.5
Date: 2009-07-02 14:35:37
Message-ID: 4A4CC5B9.5070303@dunslane.net (view raw or flat)
Thread:
Lists: pgsql-hackers

Tom Lane wrote:
> I'd like to return to the project I suggested here:
> http://archives.postgresql.org/message-id/18653.1239741426@sss.pgh.pa.us
> of getting rid of plpgsql's private lexer and having it use the core
> lexer instead.  This will require making the core lexer re-entrant,
> which is not possible with our oldest supported version of flex
> (2.5.4a).  A look at the flex change history indicates that %reentrant
> was added in 2.5.6 but nasty bugs were being fixed up to 2.5.30;
> so the new minimum supported version would probably be 2.5.33
> (2.5.31 was kinda broken for other reasons, and there was no 2.5.32).
>
> Since 2.5.33 is now over three years old, this does not seem like an
> onerous requirement, but I thought I'd better ask if anyone has an
> objection?
>
> 			
>   



I think it would need to be benchmarked. My faint recollection is that 
the re-entrant lexers are slower.

cheers

andrew

In response to

Responses

pgsql-hackers by date

Next:From: Kevin GrittnerDate: 2009-07-02 14:42:46
Subject: Re: Upgrading our minimum required flex version for 8.5
Previous:From: Tom LaneDate: 2009-07-02 14:25:15
Subject: Upgrading our minimum required flex version for 8.5

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group