Skip site navigation (1) Skip section navigation (2)

Re: BUG #4665: pgAdmin: non checking PG version on vacuum

From: Heikki Linnakangas <heikki(dot)linnakangas(at)enterprisedb(dot)com>
To: "Artiom A(dot) Makarov" <art(at)gifts(dot)ru>
Cc: pgsql-bugs(at)postgresql(dot)org
Subject: Re: BUG #4665: pgAdmin: non checking PG version on vacuum
Date: 2009-02-19 11:24:57
Message-ID: 499D4189.6000900@enterprisedb.com (view raw or flat)
Thread:
Lists: pgsql-bugs
Artiom A. Makarov wrote:
> The following bug has been logged online:
> 
> Bug reference:      4665
> Logged by:          Artiom A. Makarov
> Email address:      art(at)gifts(dot)ru
> PostgreSQL version: 8.3.5/8.3.6
> Operating system:   windows XP SP2 rus / Ubuntu 8.04 x86_64
> Description:        pgAdmin: non checking PG version on vacuum
> Details: 
> 
> pg 8.3.5 (Ubuntu 8.04 x86_64) upgraded up to 8.3.5 without dump_all /
> restore.
> 
> Running vacuum analyze from pgAdmin 8.3.5 (windows XP) on 8.3.6 database
> raise a lot of errors. After vacuum stopped with error many sequence
> randomly change values.
> 
> There are no errors when both server and pgAdmin 8.3.6.
> 
> On a my opinion, pgAdmin must deny vacuum/analyze on inconsistent version.

That should work just fine. What errors are you getting?

-- 
   Heikki Linnakangas
   EnterpriseDB   http://www.enterprisedb.com

In response to

pgsql-bugs by date

Next:From: Md. Abdur RahmanDate: 2009-02-19 11:54:01
Subject: Re: building Postgresql in Windows XP
Previous:From: Artiom A. MakarovDate: 2009-02-19 11:06:40
Subject: BUG #4665: pgAdmin: non checking PG version on vacuum

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group