Peter Eisentraut wrote:
> Another thing that is concerning me about this new approach is the way the
> probes are named. For example, we'd now have a call
> in the code. This does not say we are *tracing* lock aquisition, but it looks
> like a macro that actually acquires a lock.
Definitely a valid concern.
> I understand that these probe names follow some global naming scheme. Is it
> hard to change that? I'd feel more comfortable with, say,
Because the macro is auto generated and follows certain naming
conventions, prepending TRACE_ will not work. If you did that, the probe
name will be called "postgresql-lwlock-aquire" and the provider will be
"trace" which is not what we want.
To avoid the confusion, how about just adding a simple comment like /*
DTrace probe or Trace point or something similar */ before all
occurrences of the macro calls?
In response to
pgsql-patches by date
|Next:||From: Alvaro Herrera||Date: 2008-02-29 14:34:14|
|Subject: remove TCL_ARRAYS|
|Previous:||From: Alvaro Herrera||Date: 2008-02-29 14:10:48|
|Subject: Re: DTrace probe patch for OS X Leopard|