Skip site navigation (1) Skip section navigation (2)

Re: Problem using Slony-I with pgadmin 1.6.2

From: Dave Page <dpage(at)postgresql(dot)org>
To: Kandy Wong <kandyw(at)triumf(dot)ca>
Cc: pgadmin-support(at)postgresql(dot)org
Subject: Re: Problem using Slony-I with pgadmin 1.6.2
Date: 2007-12-14 21:37:08
Message-ID: 4762F784.7070603@postgresql.org (view raw or flat)
Thread:
Lists: pgadmin-support
Kandy Wong wrote:
> SL4 is Scientific Linux 4 and it's like CentOS 4 which is a compatible
> rebuild of the Red Hat Enterprise Linux 4. The F7 RPM doen't work for me.
> So when I tried to add a New Slony-I Cluster, the following error window
> pop up:
>
> An error has occurred:
> ERROR:  incompatible library "/usr/lib/pgsql/xxid.so": missing magic block
> HINT:  Extension libraries are required to use the PG_MODULE_MAGIC macro.
> 
> Is there a way to fix this problem?

That means the version of Slony you have is not built for the version of
PostgreSQL you are running. You need to find (or build) a Slony RPM for
your specific version of PostgreSQL.

Regards, Dave

In response to

Responses

pgadmin-support by date

Next:From: Kandy WongDate: 2007-12-15 00:56:46
Subject: Re: Problem using Slony-I with pgadmin 1.6.2
Previous:From: Kandy WongDate: 2007-12-14 21:29:53
Subject: Re: Problem using Slony-I with pgadmin 1.6.2

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group