Skip site navigation (1) Skip section navigation (2)

Re: "Something unusual has occured" error using PostgreSQL 8.2 with Apache Commons DBCP 1.2.2

From: Iván Velamazán González <ivan(dot)velamazan(at)gtbi(dot)net>
To:
Cc: pgsql-jdbc(at)postgresql(dot)org
Subject: Re: "Something unusual has occured" error using PostgreSQL 8.2 with Apache Commons DBCP 1.2.2
Date: 2007-10-24 08:24:58
Message-ID: 471F015A.1090008@gtbi.net (view raw or flat)
Thread:
Lists: pgsql-jdbc
Hello to everybody:

Matthew Storer escribió:
> On a possibly related note, I read in the Apache Commons DBCP README
> that says:
> "This release of JDBC compiles with and supports JDK 1.3 (JDBC 2.0) and
> JDK 1.4-1.5 (JDBC 3.0). JDK 1.6 (JDBC 4.0) is not supported by this
> release."  I'd like to try using PostgreSQL's JDBC3 drivers, but the
> site says that if I'm using Java 1.6 I shouldn't use that, but should
> use their JDBC4 drivers instead.  Any thoughts?
>   
Try playing with the javac "-source" option to set your source level to 
1.5. That error drove me crazy for a while untill I set up my code to be 
compatible with Java 1.5.

-- 
Iván Velamazán González


In response to

pgsql-jdbc by date

Next:From: LiuYan 刘研Date: 2007-10-24 14:03:20
Subject: Re: Chinese database name in URL, can I ?
Previous:From: Albe LaurenzDate: 2007-10-24 07:18:07
Subject: Re: "Something unusual has occured" error using PostgreSQL 8.2 with Apache Commons DBCP 1.2.2

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group