Skip site navigation (1) Skip section navigation (2)

Re: Logging autovacuum activity

From: Ireneusz Pluta <ipluta(at)wp(dot)pl>
To: Sibte Abbas <sibtay(at)gmail(dot)com>
Cc: pgsql-admin(at)postgresql(dot)org
Subject: Re: Logging autovacuum activity
Date: 2007-06-20 18:41:03
Message-ID: (view raw or whole thread)
Lists: pgsql-admin

Sibte Abbas napisaƂ(a):
> On 6/20/07, Ireneusz Pluta <ipluta(at)wp(dot)pl> wrote:
>> Hello,
>> How can I make sure that autovacuum is running, beyond believing that 
>> all autovacuum_ settings in
>> postgresql.conf are set correctly?
>> In the 8.1 I could see:
>> LOG:  autovacuum: processing database "test"
>> in the log.
>> But I can't find it in the 8.2.4.
>> I could see some developers discussions about making changes to 
>> logging autovacuum activity, however
>> could not track the discussion tight enough to find what the final 
>> solution is.
>> Thanks
>> Ireneusz Pluta
> ps -ef | grep autovacuum.
It does not show it. I run freebsd, does it matter?

Anyway, I found that I may enable logging autovacuum messages by setting:

  log_min_messages = debug1

in postgresql.conf

I found it from postgresql-8.2.4/src/backend/postmaster/autovacuum.c, where I read in line 420:

                 (errmsg("autovacuum: processing database \"%s\"", db->name)));

and this is what the developers were discussing and I did not understand initially.

Sorry for the noise.

Ireneusz Pluta

In response to


pgsql-admin by date

Next:From: Shoaib MirDate: 2007-06-20 18:52:42
Subject: Re: Logging autovacuum activity
Previous:From: Andrew SullivanDate: 2007-06-20 18:09:55
Subject: Re: Database User

Privacy Policy | About PostgreSQL
Copyright © 1996-2015 The PostgreSQL Global Development Group