Skip site navigation (1) Skip section navigation (2)

Re: build environment

From: Guillaume Lelarge <guillaume(at)lelarge(dot)info>
To: Leszek Trenkner <olaf(at)post(dot)pl>
Cc: pgadmin-hackers(at)postgresql(dot)org
Subject: Re: build environment
Date: 2007-05-09 07:31:19
Message-ID: 464178C7.3050400@lelarge.info (view raw or flat)
Thread:
Lists: pgadmin-hackers
Hi,

Leszek Trenkner a écrit :
> Thu, 03 May 2007 14:54:12 +0200, Florian G. Pflug wrote:
> 
>> I'm doing nightly builds on OSX 10.3 with wx 2.8.3, and I also sucessfully
>> built 1.6 on ubuntu edgy a few weeks ago.
>>
> 
> I'm using Ubuntu Fiesty (upgraded from edgy). I've just compiled
> pgadmin3-1.6.3 from sources without any problems. But SVN version
> (1.8?) doesn't compile - with exactly the same errors as Giuseppe
> Sacco reported:
> 
> if gcc -DHAVE_CONFIG_H -I. -I. -I..   -I/usr/include/postgresql
> -DSSL -I/usr/local/lib/wx/include/gtk2-unicode-release-2.8
> -I/usr/local/include/wx-2.8 -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES
> -D__WXGTK__ -O2 -I/usr/include/libxml2 -I/usr/include/libxml2
> -DDATA_DIR=\"/usr/local/pgadmin3/share/pgadmin3/\" -Wall
> -I../pgadmin/include  -MT keywords.o -MD -MP -MF ".deps/keywords.Tpo" -c
> -o keywords.o `test -f './db/keywords.c' || echo './'`./db/keywords.c; \
>         then mv -f ".deps/keywords.Tpo" ".deps/keywords.Po"; else rm -f
>         ".deps/keywords.Tpo"; exit 1; fi
> In file included from ./db/keywords.c:22: gram.y:122: error: expected
> specifier-qualifier-list before ‘JoinType’
> 

I have the same issue on a computer upgraded from edgy to feisty. I 
don't have it on my laptop (no upgrade, installed with feisty).

>> Please post the output of "gcc --version" on your machine, and check
>> if you have any environment variables like 
>> CC,CFLAGS,LDFLAGS,CXXFLAGS,CPPFLAGS,.. set in the shell where you
>> issue "configure" and "make". Please also add the exact arguments
>> to configure you used.
> 
> gcc (GCC) 4.1.2 (Ubuntu 4.1.2-0ubuntu4)
> Copyright (C) 2006 Free Software Foundation, Inc.
> This is free software; see the source for copying conditions.  There is NO
> warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
> 
> Just plain ./configure fails. No environment varaiables
> (CC,CFLAGS,LDFLAGS,CXXFLAGS,CPPFLAG) set in the shell. I've tried to
> compile it with SVN version of postgres 8.3 instead of
> distribution-delivered 8.2.x, but it doesn't change anything.
> 
>> [...]
>> As a crosscheck, please also try the changes to postgres.h (the one
>> shipped with the pgadmin sources, not some other postgres you might find
>> in /usr/include) that I suggested in the other thread.
>>
>> In postgres.h, replace
>> #define YYTOKENTYPE
>> #define YYSTYPE int
>> with
>> #define YYSTYPE_IS_DECLARED
>> #define DECIMAL DECIMAL_P
>>    typedef int YYSTYPE;
>>
> 
> Unfortunately, as others have reported, it doesn't help :-(
> Maybe something is wrong with Debian/Ubuntu build environments...
> 

I think a package is missing but I don't manage to find which one.

Regards.


-- 
Guillaume.
<!-- http://abs.traduc.org/
      http://lfs.traduc.org/
      http://docs.postgresqlfr.org/ -->

In response to

Responses

pgadmin-hackers by date

Next:From: svnDate: 2007-05-09 07:59:56
Subject: SVN Commit by dpage: r6275 - in trunk/pgadmin3/pgadmin: . db include include/parser utils
Previous:From: Leszek TrenknerDate: 2007-05-09 01:59:28
Subject: Re: build environment

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group