Skip site navigation (1) Skip section navigation (2)

Re: RHEL4 RPM packages

From: John R Pierce <pierce(at)hogranch(dot)com>
To: pgsql-bugs(at)postgresql(dot)org
Subject: Re: RHEL4 RPM packages
Date: 2007-03-02 03:23:49
Message-ID: 45E798C5.1090603@hogranch.com (view raw or flat)
Thread:
Lists: pgsql-bugs
John R Pierce wrote:
> RHEL4 ships with postgres 7.4.x, and various RHEL4 RPMs have a 
> dependency on libpq.so.3 ...

Using the CentOS 4 base repository, I've identified these RPMs as 
depending on libpq.so.3, which is obsoleted and removed by the 
postgresql-libs-8.2.3-1PGDG RPM ...

    cyrus-sasl-sql-0:2.1.19-5.EL4.i386
    dovecot-0:0.99.11-4.EL4.i386
    freeradius-postgresql-0:1.0.1-3.RHEL4.3.i386
    libdbi-dbd-pgsql-0:0.6.5-10.RHEL4.1.i386
    mod_auth_pgsql-0:2.0.1-7.1.i386
    perl-DBD-Pg-0:1.31-6.i386
    php-pgsql-0:4.3.9-3.22.3.i386
    qt-PostgreSQL-1:3.3.3-10.RHEL4.i386


I could see this being a real pain, for instance, if I wanted to do PHP 
or Perl work with PostgreSQL, I'd have to replace the RHEL4 version of 
PHP with something custom built.




In response to

pgsql-bugs by date

Next:From: Guillaume SmetDate: 2007-03-02 11:18:35
Subject: Re: RHEL4 RPM packages
Previous:From: John R PierceDate: 2007-03-02 02:23:46
Subject: RHEL4 RPM packages

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group