Skip site navigation (1) Skip section navigation (2)

Re: web-app not working after upgrade 7.4 to 8.1

From: Wolfgang Rinnert <wrinnert(at)web(dot)de>
To: João Paulo Ribeiro <jp(at)mobicomp(dot)com>, pgsql-jdbc(at)postgresql(dot)org
Subject: Re: web-app not working after upgrade 7.4 to 8.1
Date: 2006-12-04 18:46:26
Message-ID: 45746D02.40708@web.de (view raw or flat)
Thread:
Lists: pgsql-jdbc
Hello Joao,

João Paulo Ribeiro wrote:
> Its possible that your upgrade missed up the postgres configuration.
> Verifiy if the postgres is waiting for connections at port 5342.
> As root try:
> netstat -ntlp | grep 5432
> 
Thanks for your tip.   I tried it - that is not the problem.

What I am going to do, is write a minimal web application that connects 
to the database, and see if I can get to the core of the problem.
Since this is a hobby and I have to do it in the evening besides 
professional work and family affairs, it will take me some time.

Thanks anyways.

Wolfgang
...

> JP
> 
> 
> Wolfgang Rinnert wrote:
>> Hello experts,
>>
>> I have recently upgraded my database from 7.4 to 8.1 and migrated all
>> data.
>>
>> In order to be able to use my web-app, I replaced the old jdbc.jar
>> with postgresql-8.1-407.jdbc3.jar in WEB-INF/lib/.
>>
>> Restarted Tomcat (4.1.31) - and later even redeployed the webapp.
>>
>> I keep getting no database connection - as if the postmaster were not
>> started.
>>
>>...
>> Any hint is apreciated.
>>


In response to

Responses

pgsql-jdbc by date

Next:From: Brendon BentleyDate: 2006-12-05 12:27:32
Subject: Re: Use Driver to Create database?
Previous:From: Marc HerbertDate: 2006-12-04 16:11:17
Subject: Re: Backup with Java

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group