Skip site navigation (1) Skip section navigation (2)

Re: Can not build pgadmin3-1.6.0

From: Dave Page <dpage(at)postgresql(dot)org>
To: Bryan Wilkerson <bryanwilkerson(at)yahoo(dot)com>
Cc: Devrim GUNDUZ <devrim(at)CommandPrompt(dot)com>, pgadmin-support(at)postgresql(dot)org
Subject: Re: Can not build pgadmin3-1.6.0
Date: 2006-11-24 19:08:04
Message-ID: 45674314.4040508@postgresql.org (view raw or flat)
Thread:
Lists: pgadmin-support
Bryan Wilkerson wrote:
> Thanks for the tips.  That got me past the ./configure of pgadmin3.  Now I get an error during compile:
> 
> ./pgAdmin3.cpp: In member function ‘virtual bool pgAdmin3::OnInit()’:
> 
> ./pgAdmin3.cpp:365: error: ‘wxOGLInitialize’ was not declared in this scope
> 
> Is there another flag I need to configure wxWidgets with?   Again,  I used 
>        ./configure --with-gtk --enable-gtk2 --enable-unicode --enable-mimetype=yes 
> to build wxWidgets-2.8.0-rc1.   I can't find the documents on compiling and installing.  I'm sure I missed them.
> 
> Full text of ./configure and make of pgAdmin below...

Looks like you forgot to build and install wxWidgets' contrib modules.

Regards, Dave.

In response to

pgadmin-support by date

Next:From: Hiroshi SaitoDate: 2006-11-24 19:14:24
Subject: Re: Can not build pgadmin3-1.6.0
Previous:From: Bryan WilkersonDate: 2006-11-24 18:53:02
Subject: Re: Can not build pgadmin3-1.6.0

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group