Skip site navigation (1) Skip section navigation (2)

Re: Bus error in postgres 8.3

From: "Peter Koczan" <pjkoczan(at)gmail(dot)com>
To: "Tom Lane" <tgl(at)sss(dot)pgh(dot)pa(dot)us>, "Pavan Deolasee" <pavan(dot)deolasee(at)gmail(dot)com>
Cc: "pgsql-admin(at)postgresql(dot)org" <pgsql-admin(at)postgresql(dot)org>
Subject: Re: Bus error in postgres 8.3
Date: 2008-04-30 20:38:41
Message-ID: 4544e0330804301338j1a44dc77r6981b8046404d960@mail.gmail.com (view raw or flat)
Thread:
Lists: pgsql-admin
On Tue, Apr 29, 2008 at 1:01 AM, Tom Lane <tgl(at)sss(dot)pgh(dot)pa(dot)us> wrote:
>  Make sure the postmaster is started under ulimit -c unlimited.
>  On a depressingly large fraction of modern platforms, daemons are
>  started with ulimit -c 0 by default :-(.  Try putting "ulimit -c unlimited"
>  into your PG init script and restarting.

> On Tue, Apr 29, 2008 at 10:35 AM, Peter Koczan <pjkoczan(at)gmail(dot)com> wrote:
>  Yeah, a stack trace and if possible, a self contained test case to
>  reproduce the bug would help. If you are using a custom build, then
>  using a debug build would help a lot too.

So far, this problem hasn't reoccurred since I first saw it, no matter
how much I pummel my test server.

I was testing some patches about the time that this happened
(including one in the libpq backend), so there may have been an ABI
mismatch which led to the bus error.

In any case, I've set the postmaster to have ulimit -c unlimited in
case this problem reoccurs. I'll also look into using a debug build in
case this happens again. But until then, I'm confident enough to keep
pushing out 8.3.

Thanks again.
Peter

In response to

pgsql-admin by date

Next:From: Tom LaneDate: 2008-04-30 20:43:57
Subject: Re: 8.1.8 autovacuum missing databases
Previous:From: Tom LaneDate: 2008-04-30 20:25:49
Subject: Re: duplicate primary index in bayes db from SpamAssassin

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group