Skip site navigation (1) Skip section navigation (2)

Re: Buildproblems on OSX 10.3 due to libxml2

From: Miha Radej <miha(dot)radej(at)siix(dot)com>
To: "Florian G(dot) Pflug" <fgp(at)phlo(dot)org>
Cc: Dave Page <dpage(at)vale-housing(dot)co(dot)uk>, pgadmin-hackers(at)postgresql(dot)org
Subject: Re: Buildproblems on OSX 10.3 due to libxml2
Date: 2006-02-27 12:30:30
Message-ID: (view raw or whole thread)
Lists: pgadmin-hackers

Florian G. Pflug wrote:
> Miha Radej wrote:
>> i don't have osx but i have had problems compiling pgadmin recently. 
>> i've been getting various compiler errors about the code in 
>> xmlwriter.h as far as i could tell. my libxml2 version was 2.6.20. 
>> after upgrading to 2.6.23, pgadmin compiled fine and the errors i got 
>> before went away. this was on suse 10.0. i have a 9.3 system also and 
>> also have problems compiling pgadmin, however with different errors 
>> (an older libxml2 version).
> Hm.. sounds more like older versions of libxml2 where incompatible with
> the gcc version that comes with SuSE 10... Is this gcc 3.3, 3.4, or 4.0?

mcajvar(at)atair:~> gcc --version
gcc (GCC) 4.0.2 20050901 (prerelease) (SUSE Linux)

i think suse 9.3 comes with gcc 3.3.5, but i am not certain. i will 
check when i get my hands in the computer and will try newer libxml 
versions to see what happens.


"... the small primitive tribes joined up and became huge, powerful 
primitive tribes with more sophisticated weapons."
   -- Terry Pratchett, Small Gods

In response to

pgadmin-hackers by date

Next:From: László JózsefneDate: 2006-02-27 14:54:11
Subject: hungarian pgadmin III
Previous:From: Dave PageDate: 2006-02-27 12:22:49
Subject: Re: Query results in grid, new patch

Privacy Policy | About PostgreSQL
Copyright © 1996-2015 The PostgreSQL Global Development Group