Skip site navigation (1) Skip section navigation (2)

Re: Finding the pqlib version

From: Christoph Zwerschke <cito(at)online(dot)de>
To: pgsql-interfaces(at)postgresql(dot)org
Subject: Re: Finding the pqlib version
Date: 2006-02-15 10:41:45
Message-ID: 43F30569.9010705@online.de (view raw or flat)
Thread:
Lists: pgsql-interfaces
Peter Eisentraut wrote:
 > Christoph Zwerschke wrote:
 >> Which do you think would be the right package/feature category for
 >> pg_config for Linux/Windows? devel and Development->Tools/utilities?
 >
 > I'm not sure what these categories are supposed to mean but they don't
 > sound wrong.  To gauge the correct placement I would say that whenever
 > you install libpq-fe.h you should get pg_config in the same
 > package/module/installation.

The problem is that the Windows installer has the "Development" feature 
subdivided into "Include files", "Library files", "PGXS files" and 
"Tools and utilities". Installing pg_config along with the include files 
would be confusing in this case.

By the way, putting the "Library files" under "Development" seems a bit 
unlucky, too. It should be on the top level instead. Where should such a 
suggestion be sent to? pgsql-patches?

-- Christoph


In response to

pgsql-interfaces by date

Next:From: Christoph ZwerschkeDate: 2006-02-15 10:49:41
Subject: Re: Finding the pqlib version
Previous:From: Peter EisentrautDate: 2006-02-15 10:25:03
Subject: Re: Finding the pqlib version

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group