Skip site navigation (1) Skip section navigation (2)

Re: pam_pgsql [semi-offtopic]

From: Oswaldo Hernández <listas(at)soft-com(dot)es>
To: pgsql-es-ayuda(at)postgresql(dot)org
Subject: Re: pam_pgsql [semi-offtopic]
Date: 2006-01-24 20:56:35
Message-ID: 43D69483.4000106@soft-com.es (view raw or flat)
Thread:
Lists: pgsql-es-ayuda
Oswaldo Hernández escribió:
> Amadeo (listas) escribió:
> 
>> Hola Oswaldo, seguramente yo no te pueda ayudar porque en postgre soy 
>> super novato, pero de antemano te digo que si indicas el error que 
>> obtienes o alguna informacion de contexto, seguramente alguien te 
>> podrá ayudar.
>>  
>>  
> 
> 
> Error no me da ninguno, informacion en syslog tampoco, simplemente es 
> como si no hubiera hecho nada. Creo que el problema esta en la 
> configuración del Pam, no me esta haciendo ni pu.. caso.
> 
> La prueba la estoy haciendo para el servicio FTP (proftpd), el cual 
> tiene activado el pam por defecto.
> 
> He modificado el /etc/pam.d/proftpd añadiendole:
> 
> auth            required        pam_pgsql.so
> account         required        pam_pgsql.so
> password        required        pam_pgsql.so
> 
> He creado el archivo /etc/pam_pgsql.conf de la siguiente forma:
> 
> connectionstring = user=uuuu password=xxxxx host=127.0.0.1 port 5432 
> dbname=bdatos
> getpassword = SELECT password FROM profesoresn WHERE usuario=$1
> changepw = UPDATE profesoresn SET password = $2 WHERE usuario=$1
> isexpired = SELECT 1 FROM profesoresn WHERE user = $1 AND isexpired < NOW()
> newpassrequired = SELECT 1 FROM profesoresn WHERE user = $1 AND newpass 
> < NOW()
> debug
> 
> Todo segun la documentacion, pero no hace absolutamente nada. He llegado 
> a eliminarle todas las demas opciones de padm.d/proftpd para que solo 
> hiciera caso a estas y continua igual, como si no hubiera hecho nada.
> 
> Algo se me escapa, pero no se el que, repito que es la primera vez que 
> entro a configurar el pam.
> 
> Gracias.
> 

Bueno, parece que ya va saliendo algo.

Pam_pgsql dice que el log lo tira en syslog, pero realmente me lo esta haciendo an auth.log.
Despues de corregir algun que otro error de sintaxis y de releerme la documentacion de Linux-pam por 
decimocuarta vez, parece que funciona, aunque he ido a elegir el peor servicio para esto (ftp).

Discupad por el off-topic.

Saludos,





>> Saludos.
>>  
>>
>>     ----- Original Message -----
>>     *From:* Oswaldo Hernández <mailto:listas(at)soft-com(dot)es>
>>     *To:* pgsql-es-ayuda(at)postgresql(dot)org
>>     <mailto:pgsql-es-ayuda(at)postgresql(dot)org>
>>     *Sent:* Tuesday, January 24, 2006 6:11 PM
>>     *Subject:* [pgsql-es-ayuda] pam_pgsql [semi-offtopic]
>>
>>     Hola a todos,
>>
>>     Aunque esta cuestion es mas de linux que de postgres me atrevo a
>>     formular esta pregunta aqui.
>>
>>     Estoy intentando configurar el modulo pam_pgsql (1.0.0 descargado de
>>     pgfoundry) en debian 3.1, para validar a los usuarios del sistema
>>     mediante una base de datos postgres.
>>
>>     He compilado el modulo y lo he configurado segun las instrucciones,
>>     pero
>>     no consigo hacer que funcione (Soy novato en esto de configurar el 
>> pam).
>>
>>     ¿Alguien de la lista lo ha utilizado y me puede echar un cablecito?
>>
>>     Gracias,
>>
>>
> 


-- 
*****************************************
Oswaldo Hernández
oswaldo(at)soft-com(dot)es
*****************************************

In response to

Responses

pgsql-es-ayuda by date

Next:From: Carlos Alberto Márquez ReyDate: 2006-01-24 22:59:33
Subject: PL/R
Previous:From: Jaime CasanovaDate: 2006-01-24 20:42:55
Subject: Re: ayuda

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group