Skip site navigation (1) Skip section navigation (2)

[patch] Please drop the dangerous libssl and libcrypto deps

From: Raphaël Enrici <blacknoz(at)club-internet(dot)fr>
To: Dave Page <dpage(at)vale-housing(dot)co(dot)uk>,"Adam H(dot)Pendleton" <fmonkey(at)fmonkey(dot)net>,Andreas Pflug <pgadmin(at)pse-consulting(dot)de>,PgAdmin Hackers <pgadmin-hackers(at)postgresql(dot)org>
Cc: Loïc Minier <lool(at)dooz(dot)org>
Subject: [patch] Please drop the dangerous libssl and libcrypto deps
Date: 2005-12-26 22:58:06
Message-ID: 43B0757E.2020509@club-internet.fr (view raw or flat)
Thread:
Lists: pgadmin-hackers
Dear friends,

Loic Minier(CCed) provided a patch to prevent pgadmin3 1.2.2 from being
linked to a different libssl version than libpq when dynamically built
with an already ssl enabled libpq. The full bug report and original
patch by Loic can be found at
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=341117

Attached is an svn diff for 1.4.1 release that I'm using for the package
I'm about to upload to Debian (patch_libpqssl_1.4.1).
You'll also find a fully untested patch for trunk (patch_libpqssl_current).

Please recheck and apply if eveything's ok with them.

Cheers,
Raph

Attachment: patch_libpqssl_current
Description: text/plain (365 bytes)
Attachment: patch_libpqssl_1.4.1
Description: text/plain (543 bytes)

Responses

pgadmin-hackers by date

Next:From: Andreas PflugDate: 2005-12-27 09:48:16
Subject: Re: [patch] Please drop the dangerous libssl and libcrypto deps
Previous:From: Raphaël EnriciDate: 2005-12-26 22:36:35
Subject: pgAgent manpage

Privacy Policy | About PostgreSQL
Copyright © 1996-2014 The PostgreSQL Global Development Group